wp_pagenavi and pagination not working

resolved (20 posts) (7 voices)

  1. avatar12
    Member

    Hi there,

    Fresh install of the latest version. I can not get blog pagination to work. It does not work on the main page when set to display blogs, and it does not work on category or archive pages.

    I thought it might be something with my install, but then I noticed your demo site doesn't have it either. Is there a way to activate it?

    I see this in index.php:

     <?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>

    And I see wp-pagenavi.php in the includes lib/folder

    Posted 4 years ago #
  2. Uniq
    Support

    Hello avatar12,

    This is how the paginator looks on our demo site: http://themes.mysitemyway.com/awake/galleries/portfolio-1-column/

    I'd suggest you to download the plugin from here: http://wordpress.org/extend/plugins/wp-pagenavi/
    Install it, and see if this works!

    Cheers,
    Dorian

    Posted 4 years ago #
  3. avatar12
    Member

    I saw that your demo site has it for the portfolio section, but not the blog section. That is where I need it.

    The plugin itself does not work on my install: "Plugin could not be activated because it triggered a fatal error."

    Possibly a conflict with the script already there?

    Posted 4 years ago #
  4. Uniq
    Support

    I saw that your demo site has it for the portfolio section, but not the blog section. That is where I need it.

    It should be there for the blog section too. Not sure what's going on. Could you please let me have a link to your website so I can see what the issue could be?

    Cheers,
    Dorian

    Posted 4 years ago #
  5. avatar12
    Member

    This has to be a hosting conflict with the new wp-pagenavi version. I can get it to work on a different host.

    Posted 4 years ago #
  6. avatar12
    Member

    Yep, this was definitely a problem with the hosting environment - my local xampp. It works fine when I port it over to Hostgator. You can mark this as resolved

    Posted 4 years ago #
  7. I had the same issue just a while ago. I was able to resolve it by deactivating the theme, activating wp-pagenavi, and reactivating Awake.

    Posted 3 years ago #
  8. Uniq
    Support

    Thank you for input, gainesms! It's good to know, especially if there are people out there having the same issue!

    Marking the topic back as resolved!

    Cheers,
    Dorian

    Posted 3 years ago #
  9. Iguazu67
    Member

    Hi.

    I'm having the same problem with inFocus. I followed these steps. Deactivated the theme. Installed wp-pagenavi. Re-activated the theme. Still the same problem.

    Any ideas?

    Posted 3 years ago #
  10. Elliott
    Support

    Hello Iguazu67,

    inFocus has wp-pagenavi pre-installed so if you have the wp-pagenavi plugin in your plugin folder and activated then it will actually cause problems.

    Go ahead and deactivate and delete wp-pagenavi from your plugin folder to see if this solves your problem. If you are still experiencing issues then PM us Wordpress login details so we can take a closer look.

    Posted 3 years ago #
  11. LynneArnold
    Member

    I also have this problem. I deleted wp-page navi and re-installed it. I just get this message: "Plugin could not be activated because it triggered a fatal error."

    I also can no longer use Event Registration plugin since installing Awake. I tried the same thing, deleting it and then trying to reinstall, but it won't activate. I've tried uploading via FTP and installing from the panel. Neither works. I'd appreciate any advice. TIA

    Posted 3 years ago #
  12. LynneArnold
    Member

    I also should have added that my page navigation doesn't work at all. If i click on a second page, i get the 404 page.

    Posted 3 years ago #
  13. LynneArnold
    Member

    One more thing: I mean the plugin "Event Registration" not Event Espresso Lite. I was able to activate Event Espresso Lite, but I really need Event Registration because it connects to Google. TIA

    Posted 3 years ago #
  14. Ruderic
    Support

    Hi LynneArnold,

    Could you please provide us a link to your website, showing where the issues are occurring?

    Posted 3 years ago #
  15. Ruderic
    Support

    Hi,

    About pagenavi, could you please try to reset the permalinks, and see what happens?

    Why did you install pagenavi? This theme already includes that plugin by default.

    Posted 3 years ago #
  16. LynneArnold
    Member

    I tried installing page navi (which was unsuccessful) because the page links weren't working.

    Yes, the permalinks is the problem. Page navi works if i use the default permalinks. But i have already set up this entire site using /%category%/%postname%/. For SEO and other reasons, i do not wanted numbered pages.

    I have other sites using page navi that work just fine using /%category%/%postname%/ permalinks.

    Is the problem that you have routed some plugins into your internal coding that other plugins now will not work? Is there a workaround?

    TIA

    Posted 3 years ago #
  17. LynneArnold
    Member

    I have a couple things to finish and then launch this site tomorrow. So if you could give me some advice on how to get the pagination working, i would really appreciate it. TIA

    P.S. i wonder if custom permalinks don't work with awake page navigation, if it could be solved with a redirect in .htaccess??

    Posted 3 years ago #
  18. Elliott
    Support

    Hello LynneArnold,

    Is the problem that your page navigation shows but you cannot see any page except 1? Make sure that you do not have the wp-pagenavi plugin installed. If it is still in your plugin folder then go ahead and delete it.

    The page navigation should work with a custom permalink structure. If possible set us up with a Wordpress login so we can take a closer look at your issue.

    Posted 3 years ago #
  19. LynneArnold
    Member

    My page navigation does appear. However, if you click on a subsequent page, you'll get the 404 page. I do not have the wp-page navi installed because WP won't let me install it. That's actually why i originally posted.

    WP will not let me install wp-page navi nor Event Registration.

    I will provide my login. TIA

    Posted 3 years ago #
  20. LynneArnold
    Member

    For anyone else with this problem: deleting the custom category base (settings>permalink>optional>category base) solved the navi page problem.

    Posted 3 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme