WP Events Manager - You must request at least one space to book an event.Error

open (10 posts) (4 voices)

  1. nitinrpc
    Member

    Dear Group,

    I have been strugling with this error and it only seems to occur when I activate the InFocus Theme - the bookings section of this plug-in works with other themes but causes an issue with Infocus. I have read many different blogs and they seem to point to the problem with the select field which has a break

    <select name="em_tickets[1]
    [spaces]" class="em-ticket-select" id="em-ticket-spaces-1">
    <option selected="selected">1</option>
    <option>2</option>
    <option>3</option>
    </select>

    As you can see - the theme is for some reason adding a break in the name which might be causing the problem but not sure how to fix...

    Posted 2 years ago #
  2. nitinrpc
    Member

    Dear Group -

    This plugin is critical feature for our website and I will have to change themes if i cannot resolve this - please help since I am really loving the infocus theme.

    Posted 2 years ago #
  3. nitinrpc
    Member

    I inspected the element in iexplore and it seems that the theme is adding a space between [][]. I am not how the theme handles php code if there are square brackets and if the theme adds a space between. I have used the [raw] [/raw] tag to surround the event manager short code used in the "formatting" section of the wp-event manager settings as shown below...
    {has_bookings}
    <h3>Bookings</h3>
    [raw]#_BOOKINGFORM[/raw]
    {/has_bookings}

    Please have a look at http://178.62.30.15/?event=tttt using iexplore and you will see the space between the square brackets.

    Thank you once again.

    Posted 2 years ago #
  4. Elliott
    Support

    Hello nitinrpc,

    Try surrounding everything with the raw tags.

    [raw]{has_bookinsg}
    
    etc etc
    
    {/has_bookings}[/raw]
    Posted 2 years ago #
  5. nitinrpc
    Member

    Thanks Elliot,

    I tried this but with no luck. I even tried placing the RAW tag at higher levels - but still no luck.
    http://178.62.30.15/?event=tttt
    Is it possible for you to replicate the problem with the template - you should see the same problem.

    Posted 2 years ago #
  6. nitinrpc
    Member

    Hi Elliot,

    Have you had any luck... i have to decide to continue with this template or go with another based on what happens.

    Thanks

    Posted 2 years ago #
  7. Elliott
    Support

    I do not know. Have you tried contacting the plugin authors?

    Posted 2 years ago #
  8. nitinrpc
    Member

    The problem is that I cannot replicate the problem using another theme...If I use the WP theme - I don't get the same issue. I will try to leverage the plugin authors and see if something can be done.

    Posted 2 years ago #
  9. rnmahler
    Member

    This seems to still be a problem, I have tried using this plugin and am having a similar problem

    Posted 1 year ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme