Warning\: Illegal string offset 'blog_layout' error fix

open (3 posts) (2 voices)

  1. debmc99
    Member

    Once I updated WP I was getting this message on all of my pages:

    Warning\: Illegal string offset 'blog_layout'...

    In case anyone else is having this problem, I found this website below and added the code to the config.php file to turn off the error message which apparently is happening with latest WP update. It totally fixed the problem.

    https://wordpress.org/support/topic/disable-error-reporting-in-wordpress

    Posted 1 year ago #
  2. OnePressTech
    Member

    Usually the following setting in wp-config will do the trick:

    define('WP_DEBUG_DISPLAY', false);

    The ultra-paranoid combo would be this :-)

    define('WP_DEBUG_DISPLAY', false);
    error_reporting(0);
    @ini_set('display_errors', 0);

    Posted 1 year ago #
  3. OnePressTech
    Member

    I forgot to say "thanks for sharing this debmc99" :-)

    Posted 1 year ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme