Video embed for Youtube and Vimeo videos not working in slider

resolved (96 posts) (14 voices)

  1. ajrenk
    Member

    I have the same problem and I'm not able to get a vimeo or youtube video to play properly. I have tried some of the suggestions in the previous posts, but they didn't seem to work.

    Are there any other suggestions? Dorian, are you still looking in to these on an individual basis?

    Thanks

    Posted 4 years ago #
  2. Uniq
    Support

    Hello Mank,

    I've resolved all the issues and I've got your slider working! Enjoy! Sorry for the delay!

    Best Regards,
    Dorian

    Posted 4 years ago #
  3. I purchased Awake today and I have purchased InFocus in the past and been very happy with it.

    Re: Awake, I have uploaded the video to the first slider (in partial staged) mode. The video comes up and I can play it but then it quickly switches over to the next slide. Is there a way to let the video play when the user clicks on Play. It kinda defeats the purpose of having a video on the slider if the user is unable to watch the video. Any help in this area would be highly appreciated.

    Thanks
    Nabeel

    Posted 4 years ago #
  4. Uniq
    Support

    Hello Nabeel,

    Could you let us have a link to your website, please?

    Best Regards,
    Dorian

    Posted 4 years ago #
  5. http://yourstoryisyoursuccess.com.s101257.gridserver.com/

    The issue is since its under construction for a client, we cant make it public for too long -- what do you suggest is the best way to tackle this? A time frame that works for you guys and we can remove the under construction page?

    Posted 4 years ago #
  6. Uniq
    Support

    Hello nabeelahmed,

    Just supply me with the login information so I can bypass the under construction page, then I can take a look at this.

    Best Regards,
    Dorian

    Posted 4 years ago #
  7. servaunt
    Member

    We are having the same issues on a site we are building. We will take it out of under construction mode, so you can advise. It's http://www.patchadamsclinic.org.

    I also noticed this warning message:
    Warning: Expected declaration but found '*'. Skipped to next declaration.
    Source File: http://www.patchadamsclinic.org/wp-content/themes/awake/lib/scripts/galleria/themes/classic/galleria.classic.css
    Line: 10
    Could it have anything to do with our problem?

    Thank you,
    jim and marcus

    Posted 3 years ago #
  8. Elliott
    Support

    Hello servaunt, sorry for the late reply.

    On your site the following image cannot be found, http://www.patchadamsclinic.org/wp-content/uploads/2010/12/keep_in_touch.png.

    I'm not sure if that is what is causing the bug or not but go ahead and change that so the 404 disappears and we will continue.

    Posted 3 years ago #
  9. servaunt
    Member

    Sorry for the delay. I've corrected that.

    Posted 3 years ago #
  10. Elliott
    Support

    Hello servaunt,

    I see that you switched the image but it still cannot be found,

    http://www.patchadamsclinic.org/wp-content/themes/awake/styles/_shared/default_movie_thumb_small.png

    Try using the Wordpress upload system by editing a post or page and clicking on add an image. It will spit out the exact URL for you to use.

    Posted 3 years ago #
  11. servaunt
    Member

    I eliminated that image. And I have no idea where the default_movie_thumb_small.png reference is coming from. That file is missing from the referenced folder. Does it need to be there?

    Also, there are no images in the slider settings, only youtube video url's.

    Posted 3 years ago #
  12. Elliott
    Support

    You are using the tabbed slider servaunt?

    Try placing at least one image in the slider to see if this fixes it.

    Posted 3 years ago #
  13. servaunt
    Member

    That makes it work except for the 1st video. It shows the image only. Perhaps we'll need to just have the 1st element a description overlaying an image. Do you think there's anything else you can do?

    Posted 3 years ago #
  14. Elliott
    Support

    I think this was a bug that was fixed in 1.3. Make sure you are using the latest version of Awake (1.3).

    If updating does not fix it then you can try the solution in this thread,

    http://mysitemyway.com/support/topic/video-embed-for-youtube-and-vimeo-videos-not-working-in-slider#post-3040

    Posted 3 years ago #
  15. servaunt
    Member

    I uploaded the new js file and it fixed the problem. Thank you.

    Posted 3 years ago #
  16. Elliott
    Support

    Glad that fixed it for you servaunt, if you have any other questions or issues then let us know.

    Posted 3 years ago #
  17. RStron1
    Member

    Hello Everyone,

    I finally got the video and a picture up on my slider - but I have an idea - can we make it to where the video auto plays and the video IS NOT clickable and redirects to Youtube - as we all know when people leave your site they rarly come back - I know the html code to do it but can I insert into the theme somewhere?

    Thank you everyone - this forum has been a lifesaver !!! I love this theme but a little akward to use !!!

    Posted 3 years ago #
  18. RStron1
    Member

    The site I am working on for a client is http://www.stlmarines.org

    Posted 3 years ago #
  19. Ruderic
    Support

    Hello RStron1,

    Go to the theme folder and open the file "lib/classes/video.php".

    Starting in line #206, you will find the code that generates the Youtube link for the iframe.

    If you are not comfortable editing PHP code, send us the HTML code that you usually use to accomplish your goals, and we will send you the modified PHP code.

    Posted 3 years ago #
  20. RStron1
    Member

    @ Ruderic - thank you I should be ok - I will look at it and see what I can do now that I know where to go and that it is possible - I also noticed with my site that since I have videos in the slider - sometimes you can hit the play button on the Youtube video and the slider goes to the next slide and does not play the video - it happens every so often - I have stepped up the wait time on the auto sliding to 10 seconds instead of the default 5 - that really didnt help much.

    Posted 3 years ago #
  21. RStron1
    Member

    I am also noticing that while one of the videos are playing that the slides still automatically switch.....weird. I have found that this only happens if I am on really any page but the Home Page.

    Posted 3 years ago #
  22. Elliott
    Support

    Hello RStron1,

    I checked your site regarding the videos sliding before it is loaded but they were playing fine for me. What you can try is increasing the transition speed, turning automatic transitioning off, or switching to the tabbed slider.

    Try these things out to see if you are experiencing the same issues.

    Posted 3 years ago #
  23. RStron1
    Member

    Hi Elliot - I went into the FTP manager and am not really sure how to edit what I found - am I in the right spot?

    Attachments

    1. 5-3-2011_8-56-51_AM.gif (25.9 KB, 0 downloads) 3 years old
    Posted 3 years ago #
  24. Elliott
    Support

    It depends on what your trying to edit. All of the settings in my previous post can be changed in Dashboard -> inFocus -> Homepage.

    Posted 3 years ago #
  25. RStron1
    Member

    Hello Elliott,

    I build out this code for a youtube video to auto play and make it to where it is not clickable and bounces people to youtube - how can I get this into the slider?

    <iframe allownetworking="internal"width="560" height="349" src="http://www.youtube.com/embed/_bVM_fBv5_4?&autoplay=1&rel=0" frameborder="0" allowfullscreen></iframe>

    This is going to be awesome for the Marines Corp group - they are really loving the site so far.... they are excited to see how far we can go with this theme - I am now also attracting other Marine Corp groups wanting sites built..... lol

    Posted 3 years ago #
  26. RStron1
    Member

    Oops Sorry Elliott ,

    I apologize - the note on the changes for the youtube videos to autoplay and not be clickable should have went to Ruderic - but are you able to answer the question?

    Posted 3 years ago #
  27. Elliott
    Support

    Oh I see,

    I haven't tested this out yet but you can try opening up /wp-content/themes/awake/lib/classes/video.php and on line 32 you should see this,

    'autoplay' => 0,

    Change it like this,

    'autoplay' => 1,

    Go ahead and try that out and let us know if it works for you okay RStron1.

    Posted 3 years ago #
  28. RStron1
    Member

    Hi Elliott -

    Sorry for this dumb question but is that in the FTP files in GoDaddy or in the wordpress in the theme settings?

    Posted 3 years ago #
  29. Elliott
    Support

    It's in the video.php file which is part of Awake. In your image above you have it selected with your file manager.

    You can use FTP to edit it or try the GoDaddy file manager.

    Posted 3 years ago #
  30. RStron1
    Member

    Ok I got in there - but here is another question - if I do that in the script - will all the videos auto play ?

    I really only want the video on the first slide to auto play on http://www.stlmarines.org

    Thank you so much for the help - you guys rock!

    Posted 3 years ago #
  31. RStron1
    Member

    Ok went in and added the autoplay as you suggested and it works - makes all the videos auto play but the auto slider then kicks in and moves onto the next slide - is there a way to make the auto slider not slide while a video is playing -...... geesh I am needy arent I.... trying to reinvent the wheel here..... sorry !

    The other thing is how can we make the video unclickable?

    Posted 3 years ago #
  32. RStron1
    Member

    Maybe found a spot for the script to where it makes it not clickable

    Attachments

    1. 5-3-2011_10-19-54_AM.gif (17.1 KB, 0 downloads) 3 years old
    Posted 3 years ago #
  33. Elliott
    Support

    This will be a little more difficult.

    Open up /wp-content/themes/awake/lib/functions/sliders.php and on line 85 you should see this,

    $slider_video = '[youtube framed="0" height="' .$img_height. '" width="' .$img_width. '"]' .$$slider_img. '[/youtube]';

    Go ahead and change it like this,

    if ($counter == 0) { $custom_autoplay = "autoplay='1'"; }
    $slider_video = '[youtube framed="0" '.$custom_autoplay.' height="' .$img_height. '" width="' .$img_width. '"]' .$$slider_img. '[/youtube]';

    This will make it so that if the first slide is a video then it will autoplay for youtube videos only. If you are using the tabbed slider then you will need to do the same thing on line 205.

    Posted 3 years ago #
  34. RStron1
    Member

    Here are screen shots of what I did - I think I did it right....

    Attachments

    1. after.gif (8 KB, 0 downloads) 3 years old
    2. before.gif (7.2 KB, 1 downloads) 3 years old
    Posted 3 years ago #
  35. RStron1
    Member

    this is the before picture

    Attachments

    1. before.gif (7.2 KB, 1 downloads) 3 years old
    Posted 3 years ago #
  36. RStron1
    Member

    It doesnt seem to work as I expected....

    Posted 3 years ago #
  37. Elliott
    Support

    Is it working for you RStron1? I'm not sure what you mean by unclickable. Do you mean you wish to hide the playback controls?

    Posted 3 years ago #
  38. RStron1
    Member

    well the videos start auto playing but the slider still auto slides and moves onto the the next slide without finishing the video -

    on the "unclickable" request is where when you click on the inside of the video it "normally" opens a new page for Youtube - I do not want this to happen - when you add - allownetworking="internal" - this makes it when you click on the video it just stops the video and not open a new page for you tube or redirect you to youtube

    I can provide an example if you would like

    Posted 3 years ago #
  39. RStron1
    Member

    I went and put the code on one of my old blogs as a test so you can see what I am talking about

    If you click inside where the video is playing it just pauses it not redirecting to youtube - also notice the video autoplays!!1

    http://robertstrongmarketing.org/uncategorized/test-video/

    Posted 3 years ago #
  40. Elliott
    Support

    It should stop sliding when the play button is clicked. I'm not sure why it isn't working for you. You can try taking off the auto rotation in Dashboard -> inFocus -> Homepage and let the user cycle through the slides.

    I couldn't get the allownetworking option to work. Perhaps it's only available when used with the new iframe embed code. We'll take another look when the new framework is launched.

    Posted 3 years ago #
  41. RStron1
    Member

    Hi Elliott

    I can get the allownetworking to work with the new or old code on my site - I can do a test on a regular page on http://www.stlmarines.org and see how that works - this will be really cool if we can get this figured out!

    Posted 3 years ago #
  42. RStron1
    Member

    Hello Elliott,

    I have the old code used by youtube on the follow post - this has the auto play and the "unclickable" screen the bounces people off the site -

    http://www.stlmarines.org/uncategorized/test-old-code/

    Posted 3 years ago #
  43. RStron1
    Member

    This is the old code = <p><object height="349" width="560"><param name="movie" value="http://www.youtube.com/v/_bVM_fBv5_4?fs=1&hl=en_US;&autoplay=1&rel=0" /><param allownetworking="internal" name="allowFullScreen" value="true" /><param name="allowscriptaccess" value="always" /><embed allowfullscreen="true" allownetworking="internal" allowscriptaccess="always" height="349" src="http://www.youtube.com/v/_bVM_fBv5_4?fs=1&hl=en_US;&autoplay=1&rel=0" type="application/x-shockwave-flash" width="560"></embed></object></p>

    Hope this helps - and I do apologize for being so persistent!

    Posted 3 years ago #
  44. RStron1
    Member

    I figured it out and I was right adding the coding as shown below makes the video pause and not open a new page for youtube or redirect people off the page!!!!

    Attachments

    1. old.gif (5.6 KB, 1 downloads) 3 years old
    Posted 3 years ago #
  45. RStron1
    Member

    this is the new code

    Attachments

    1. new.gif (10.3 KB, 0 downloads) 3 years old
    Posted 3 years ago #

Reply »

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme