Twitter stopped working on AWAKE

resolved (43 posts) (18 voices)

  1. freshweb_cdn
    Member

    It happened about 8 months ago and I made suggested changes that fixed it. It was because of a change with twitter API???? Now it has stopped again. Any ideas?

    Posted 4 years ago #
  2. Elliott
    Support

    Hello freshweb_cdn,

    Are you using the latest version of Awake? Deactivate all plugins and send us a link.

    Posted 4 years ago #
  3. jonathanfry
    Member

    Hi

    I believe the problem is down to the changes Twitter have made to their API ?
    https://dev.twitter.com/blog/api-v1-is-retired

    I got an email from a RapidWeaver developer this morning informing everyone that if you have a Twitter feed on your website it will no longer work and voila... our Twitter feed in our Awake theme has now stopped working !

    Of course... this isn't good news for Awake WordPress theme users who liked that feature. Hopefully a quick fix and a version update from Mysiteway ?

    Posted 4 years ago #
  4. Elliott
    Support

    It looks like they changed it so you have to use authentication now. I'll let our devs know about this and we'll see what we can do.

    In the meantime it would be best to use the twitter widget pro plugin, http://wordpress.org/plugins/twitter-widget-pro/.

    It comes with a widget and shortcodes that you can use to display your tweets. We can do some CSS edits to make it use the same styling as our twitter widget.

    To get started navigate to Dashboard -> your theme -> Skins -> Manage Skins -> Advanced and around line 23 you should see something like this,

    .colorscheme_sprite,
    #intro .tweet,#outro .mysite_twitter_widget li,
    .mysite_twitter_widget li,.recentcomments,.contact_widget_name,.contact_widget_phone,.contact_widget_email,
    .toggle,.toggle_accordion,.active,.toggle_frame .toggle,.toggle_frame .toggle_accordion,.toggle_frame .active,
    .fancy_list .arrow_list,.fancy_list .bullet_list,.fancy_list .check_list,.fancy_list .circle_arrow,.fancy_list .triangle_arrow,.fancy_list .comment_list,.fancy_list .minus_list,.fancy_list .plus_list,.fancy_list .star_list,.sitemap_list li,
    blockquote,.download_link,.email_link,.twitter_link,.dropcap,.dropcap3{/*:Icon Sprite*/
    background-image:url(_sprites/custom_sprite_1fb3dd.png);}

    Which is setting the sprite icons. Add a class of "widget_twitter li" to it like so,

    .widget_twitter li, .colorscheme_sprite,
    #intro .tweet,#outro .mysite_twitter_widget li,
    .mysite_twitter_widget li,.recentcomments,.contact_widget_name,.contact_widget_phone,.contact_widget_email,
    .toggle,.toggle_accordion,.active,.toggle_frame .toggle,.toggle_frame .toggle_accordion,.toggle_frame .active,
    .fancy_list .arrow_list,.fancy_list .bullet_list,.fancy_list .check_list,.fancy_list .circle_arrow,.fancy_list .triangle_arrow,.fancy_list .comment_list,.fancy_list .minus_list,.fancy_list .plus_list,.fancy_list .star_list,.sitemap_list li,
    blockquote,.download_link,.email_link,.twitter_link,.dropcap,.dropcap3{/*:Icon Sprite*/
    background-image:url(_sprites/custom_sprite_1fb3dd.png);}

    You'll also need to add it in /wp-content/themes/[your_theme]/shortcodes.css around lines 593 - 597,

    /* Twitter Widget
    -------------------------------------------------------------- */
    .mysite_twitter_widget ul{list-style:none;padding-left:0;}
    .mysite_twitter_widget li, .widget_twitter li {background:url(images/shortcodes/sprites/custom_sprite_dddddd.png) no-repeat -538px -76px;padding-left:28px;}
    .mysite_twitter_widget li a{display:block;}

    `

    Posted 4 years ago #
  5. Hi there,

    Have the same problem however can't really go and use the Twitter Pro plugin.

    Not only do we have 12 sites but we also feature a Twitter feed on posts we do for others advertising events with us, we have about 20 posts each with an individual Twitter feed.

    Would you mind keeping us upto date on any proper fixes for this please Elliott?

    We currently use
    inFocus, Construct & Echelon.

    Thanks, Pete

    Posted 4 years ago #
  6. Elliott
    Support

    Yes, we'll see if we can get a fix worked out soon.

    Posted 4 years ago #
  7. wdwalrus
    Member

    thanks, Elliott!

    We know and trust you'll keep us posted - as always!

    Posted 4 years ago #
  8. Same thing going on here. Glad to see they are working on a fix. Thanks Elliot!

    Posted 4 years ago #
  9. Also not working for Elegance theme. Always good to know you guys are working on a fix! My clients will be glad when this is up and running again!

    Posted 4 years ago #
  10. theimagedoc
    Member

    If you KNEW the API was being deprecated, and WHEN it was being deprecated - as indicated by other posts here on the forum and Twitter's own published road map - why didn't you issue a fix before this happened???

    Regardless, I see updated plug-ins being released, and updated themes being released already.

    Now four days have passed since "last contact" with MSMW...when will the corrected file be released???

    Posted 4 years ago #
  11. Thank you Elliott, but even after installing the recommended plugin and tweaking the css codes, it doesn't show any tweets. Any other ideas? Thank you.

    Posted 4 years ago #
  12. Now, it seems the MSMW Twitter style has completely vanished from my site. What can I do? Thank you.

    Posted 4 years ago #
  13. I uninstalled the Twitter plugin and hope to hear how to resolve MSMW about updating. thanks.

    Posted 4 years ago #
  14. freshweb_cdn
    Member

    Any word on an update? I installed twitter pro and followed the instructions... the tweets appear but tthe formatting is still bad.

    Posted 4 years ago #
  15. Elliott
    Support

    The update is being worked on. In the meantime you can use the twitter widget pro plugin and this CSS, http://mysitemyway.com/support/topic/twitter-stopped-working-on-awake#post-126287.

    Posted 4 years ago #
  16. For those of us who maintain multiple sites with MSMW themes, the plugin/CSS option isn't practical. My solution is to deactivate the shortcode until you have a fix. I'm guessing we'll have to reinstall the entire theme - again - for each site to fix this. I just did manual reinstalls for theme updates a couple of weeks ago. It's getting tedious.

    Posted 4 years ago #
  17. Hi!

    I'm sorry about this. Just replacing the files using a FTP client isn't working for you?

    -roch

    Posted 4 years ago #
  18. pdelve18
    Member

    Also having major problems @ http://www.concertnewsonline

    Any ideas when this fix will be available?

    Thank you.

    Posted 4 years ago #
  19. Elliott
    Support

    It will be out soon. In the meantime you can use the twitter widget pro plugin, http://mysitemyway.com/support/topic/twitter-stopped-working-on-awake#post-126287.

    Posted 4 years ago #
  20. keithmahon
    Member

    Any more update when fix will be available?

    Posted 4 years ago #
  21. Elliott
    Support

    Themes have been updated, http://mysitemyway.com/theme-updates-for-06-20-13/.

    Posted 4 years ago #
  22. Do we upload the entire THEME or just specific files? In this case the TWITTER updates? Thanks.

    Posted 4 years ago #
  23. Elliott
    Support

    The entire theme. See here, http://mysitemyway.com/docs/index.php/Updating_your_theme.

    Posted 4 years ago #
  24. Okay. Thank you! Thanks for the speedy update for Twitter as well!!

    Posted 4 years ago #
  25. I uploaded this file, but what version is this called? I don't see anything in my dashboard to ACTIVATE.

    Posted 4 years ago #
  26. Elliott
    Support

    If you follow the instructions in the link then you would completely delete your theme and then download / upload a fresh copy. You don't have to activate anything.

    After updating navigate to Dashboard -> your theme -> General Settings and fill out the new twitter information. You'll need to login to your twitter account and "create a new app" to receive a consumer and secret key. Twitter requires authentication now.

    Posted 4 years ago #
  27. Thanks. But, whatever version I uploaded has nothing about a new twitter info, hence my need for assistance.

    Posted 4 years ago #
  28. Elliott
    Support

    Send us a link.

    Posted 4 years ago #
  29. I have several different twitter feeds for different customers. Previous to the latest update I was using the shortcode [twitter id="twittername" number="5"]

    This shortcode doesn't seem to be working with the new authentication API. Is there a way to have multiple twitter feeds for different pages?

    Posted 4 years ago #
  30. Please disregard my previous post. Everything seems to be working...thanks!

    Posted 4 years ago #
  31. Elliott
    Support

    @VenusVenus, Your still using version 3.1. Please read and follow the instructions here, http://mysitemyway.com/docs/index.php/Updating_your_theme, and completely delete your current theme via FTP before downloading / uploading a fresh copy from themeforest.

    Posted 4 years ago #
  32. It was just too easy! Thanks.

    Posted 4 years ago #
  33. Artifex10
    Member

    Hi Elliot-
    We managed to do the update and get the twitter feed working again. But we lost the twitter bird icon... is there a way we can get it back?

    http://www.artifex10.com

    Thanks for the updates!

    Posted 4 years ago #
  34. Elliott
    Support

    It looks like your skin CSS has the wrong URL set. Try setting the following to 777 permissions,

    /wp-content/themes/[your_theme]/styles/

    And then create a new skin, edit it, and save.

    Posted 4 years ago #
  35. Pauw
    Member

    I made quite some changes in the theme. Is it possible to only update the twitter file(s) for now, that I update the complete theme later?

    Posted 4 years ago #
  36. Elliott
    Support

    You can view our changelogs here, http://mysitemyway.com/docs/index.php/Category:Changelogs, to see which files were changed.

    Posted 4 years ago #
  37. Thanks for updating the themes so this will work again. The old style on the feed seems to have gone away with the twitter bird and sans serif font. How can we get that back?

    Posted 4 years ago #
  38. Elliott
    Support

    That was only for very old versions of inFocus I believe. Send us a link and we'll take a look.

    Posted 4 years ago #
  39. cleverdaisies
    Member

    Hi There,

    Thank you for your updates. We followed this and updated the theme files and the twitter widget works, but the links to the tweets don't seem to be right. Any suggestions?

    http://www.wallaceandweese.ca/blog/

    Posted 4 years ago #
  40. Hi Elliott

    I'm trying to find out where to download the latest version of your awake and infocus themes to fix the twitter problem mentioned in this post.

    from memory, in the past i just went to the "My Downloads" section and our prior purchase was there and we could download an updated version?

    I can't see anywhere from within my account once logged in to download the latest versions, could you please advise where we get these from?

    Thanks

    Posted 4 years ago #
  41. Elliott
    Support

    You can download them from your themeforest downloads page where inFocus and Awake were initially purchased.

    Posted 4 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme