Testimonials and WP 3.9/Construct 1.6 Missing Text

pending (11 posts) (5 voices)

  1. Since updating to Construct 1.6 then updating to WP 3.9 Testimonials has stopped accepting text. It takes the image file and the name but deletes the text of the testimonial. This happens if copied and pasted, typed, in both visual and text modes. This is only in new adds, Existing testimonials are showing fine. The actually are set to show on the Biography page, bottom.

    The site is http://puptales.org

    Any ideas?

    Posted 3 years ago #
  2. PS - Just for the record, I first uploaded the files via FTP for Construct 1.6 then updated to WP 3.9.

    I just re-uploaded the Construct 1.6 files and same result.

    Posted 3 years ago #
  3. Elliott
    Support

    Hello MichaelAlbany,

    I'll flag this for the rest of our team to take a look. When we find a fix we'll update this thread.

    Posted 3 years ago #
  4. Same for me on method 2.3

    Posted 3 years ago #
  5. pixelboy7734
    Member

    Same for me on Elegance ver 2.6.

    Doesn't happen in Elegance ver 2.5.

    Posted 3 years ago #
  6. Elliott
    Support

    Please stop posting in this thread. It knocks the waiting status off.

    Posted 3 years ago #
  7. Webtreats
    Support

    Hi Everyone,

    Replace the following file on your server with the one attached to this post:

    lib/admin/classes/metaboxes-generator.php

    Don’t forget to unzip the file first.

    Let us know if this works.

    Attachments

    1. metaboxes-generator.zip (1.5 KB, 37 downloads) 3 years old
    Posted 3 years ago #
  8. Webtreats, Sorry it took me 2 days to see this but my RSS feeder sucks.

    This did not work. PM me if you would like access to the site. that can be arranged.

    Posted 3 years ago #
  9. pixelboy7734
    Member

    The problem was solved for me by reverting to these files from ver 2.5 :
    lib/admin/classes/option-generator.php
    lib/admin/functions/core.php

    "core.php" has a kludge-y fix in it that makes the testimonials not work.

    Posted 3 years ago #
  10. pixelboy - That sort of solved it for me. The issue I have now is there is no GUI, or "Visual" mode, just code and my clients don't do code. I don't have time to do all their testimonials. Any suggestions?

    Posted 3 years ago #
  11. @webtreats
    Yes and no on the fix. I can add them now and the text remains. However you can't see existing testimonials. You can only see the last one posted. Even then they show with an error

    'Fatal error: Call to protected method WP_List_Table::row_actions() from context 'mysiteTestimonial' in /home/content/05/12541705/html/wp-content/themes/construct/lib/admin/classes/testimonials.php on line 135'

    Screenshot attached.

    Attachments

    1. Screen_Shot_2014-09-05_at_9.47.39_AM.png (85.2 KB, 3 downloads) 3 years old
    Posted 3 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme