Shortcode for Blog (_grid, _list) breaks after wp update 4.7.1 using dejavu-BST

open (7 posts) (2 voices)

  1. Hello,

    unfortunately the short code for Blog (_grid, _list) breaks after wp update using dejavu-BST.

    Shortcode (see also http://mysitemyway.com/docs/index.php?title=Blog_Shortcode) is for example:

    [titled_box title="Erfahren Sie mehr über die Effekte von EMDR"]
    [blog_list thumb="small" post_content="excerpt" post_in="4505" disable="meta"]
    [/titled_box]
    <p style="text-align: justify;">Bitte lesen Sie dazu auch die <a href="http://www.remstim.com/remstim-erleben/wichtige-informationen/">wichtigen Informationen</a>.</p>
    [divider]
    <h2>Mehr über EMDR im Coaching</h2>
    [blog_grid column="2" showposts="4" offset="4" post_content="excerpt" category_in="53" disable="meta"]

    Somebody any idea how I can fix this? I really need help!

    For example please take a look at:

    http://remstim.com
    or
    http://remstim.com/grundlagen/flexible-augenbewegungen/

    Thank you!

    Best
    Tom

    Attachments

    1. Blog3.jpg (108.7 KB, 0 downloads) 4 months old
    2. Blog2.jpg (108.6 KB, 1 downloads) 4 months old
    Posted 4 months ago #
  2. OnePressTech
    Member

    Hi Tom,

    Can you clarify what the problem is. I can't see any issue with the sites you provided links for. They look fine to me so I must be missing something.

    Cheers,
    Tim

    Posted 4 months ago #
  3. OnePressTech
    Member

    Hi Tom,

    I notice in your source code that you have some unterminated paragraphs (<p> html). This is a known WordPress wpautop collision with shortcodes.

    Try wrappering your shortcode with [raw][/raw].

    Others have been reporting similar issues to me all of which were corrected through the use of [raw][/raw].

    Let us know how you go.

    Cheers,
    Tim

    Posted 4 months ago #
  4. Dear Tim,

    that works perfectly! Great! You did it again!

    Thank you very much!

    Only if your time allows it. Would you mind to explain, why this issue occurs with the newest wp-update. It had never appeared before. Only if you have an idea.

    Thanks!
    Cheers,
    Tom

    Posted 4 months ago #
  5. OnePressTech
    Member

    Hey Tom,

    I'm glad that worked for you.

    I can't say why this issue has started to appear when it did not appear before. Perhaps the better question is "why was it working before?" :-)

    Cheers,
    Tim

    Posted 4 months ago #
  6. Hi Tim,

    ok, thank you. For sure is that it has nothing do with dejavu-BST because I checked it with the old dejavu v2.8 which produced the same issue!

    Cheers,
    Tom

    Posted 4 months ago #
  7. OnePressTech
    Member

    Thanks for the update Tom...good to know I didn't bust anything...I'm trying to be cautious when I make upgrades to ensure quality always improves :-)

    Cheers,
    Tim

    Posted 4 months ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme