PrettyPhoto + Youtube on same page problems

resolved (7 posts) (2 voices)

  1. avatar12
    Member

    Prettyphoto objects open behind any embedded youtube objects. So if you have a youtube movie, and a [facy_images] shortcode under it... when you click on the photo, it opens up but the youtube video sits on top of it.

    Is there anyway to properly hide that youtube video or force prettyphoto over it?

    I can set up a test page for you to see this happen, but it is easy to do on your own. Just embed any youtube video using their iframe and them put a [fancy_images] image below it, then view that post and click on the image.

    Posted 3 years ago #
  2. Elliott
    Support

    Hello avatar12,

    It looks like this is a known issue with prettyPhoto, http://forums.no-margin-for-errors.com/discussion/171/overlay-does-not-cover-youtube/p1

    I was using the new embed iframe code but could not hide it with the "hideflash: true" setting. Perhaps they will update the scripts for this soon.

    Posted 3 years ago #
  3. avatar12
    Member

    Thanks, I saw that... was thinking I wasn't the only Awake user who might have run into and that maybe you had worked your magic on a fix.

    Hmmmm, well, I wonder if the other 'lightbox" options that are out there have the same problem? I'd think about switching if that were the case. It is pretty debilitating to any post that includes images and video.

    Posted 3 years ago #
  4. Elliott
    Support

    Have you considered placing your video inside prettyPhoto?

    Posted 3 years ago #
  5. avatar12
    Member

    I stumbled upon a solution when I found an older video on my site that didn't have this problem. This appears to work, at least for youtube.

    The parameter that needs to be added to the youtube embed link is "wmode=transparent"

    So if your embed code is: <iframe width="425" height="349" src="http://www.youtube.com/embed/TZUPuKOa_ys?rel=0" frameborder="0" allowfullscreen></iframe>

    You could add ?wmode=transparent" to the end of the video link... like this: <iframe width="425" height="349" src="http://www.youtube.com/embed/TZUPuKOa_ys?wmode=transparent" frameborder="0" allowfullscreen></iframe>

    That knocks rel=0 out of the code (hide relative videos), and I don't know how to avoid that, but it is a trade off I'm ok with.

    Placing it inside PrettyPhoto is a great idea too. Going to try that as well.

    Posted 3 years ago #
  6. Elliott
    Support

    Thanks for posting your solution avatar12, i didn't think about checking the wmode param.

    As for the rel=0 try this,

    <iframe width="425" height="349" src="http://www.youtube.com/embed/TZUPuKOa_ys?wmode=transparent&rel=0"

    Posted 3 years ago #
  7. avatar12
    Member

    Perfect, thanks as always.

    Posted 3 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme