My Wordpress Blog is not showing Pages and Menus with 'Awake' Theme

pending (8 posts) (2 voices)

  1. Hi.

    I hope someone can help. I am pulling my hair out! I setup a WordPress site on my Windows Server 2008 and IIS server. I made sure I used the WP 3.2.1 IIS installation package.

    With some themes, my Pages show up OK and in others they do not. I took the plunge and paid for a pro theme (Awake) but I am having the same problem with that!

    If I go to Dashboard and click on 'Pages', I have several pages listed that I have created. But when I go to Menu to add these pages to a Menu, none of them are listed, so I can't add them to any new menu's that I create.

    Equally, I have created a 'Contact Us' page, using the "Contact Form" shortcode. The page works if I click on it from the Dashboard, but I cannot get a link to it from the main website! I also have aanother Contact Us page that I created before using the Awake theme, and with a previous version that was displayed as part of the menu, but I can't get that to show at all now.

    What I have noticed is if I got to Menu's and create a couple of menu's, and then if I choose one of thes from the 'Primary Menu' drop down menu on the left in the 'Theme Locations' and click save, not only does the menu still not appear, but the 'HOME' link, that is currently the only menu that is every displayed, dissappears entirely! If I delete them from that list again, it re-appears.

    Can someone please explain what I am doing wrong? This is happenign me not only with this theme, but one or two others, but with a couple of other themes, they show up fine. So it must be specific to certain themes, the awake one included. My previous story about this subject is here : http://wordpress.org/support/topic/published-pages-not-showing-up-on-blogstill-2-years-later?replies=5

    My website is http://www.tedtechnology.co.uk

    Scr Shots of my problems :
    http://imageshack.us/f/685/contactusx.png/ (shows Contact Page, but no way to navigate to it)
    http://imageshack.us/f/695/menusb.png/ (Shows my Menu section with an empty "Pages" box bottom centre)
    http://imageshack.us/f/89/pagesf.png/ (shows my valid Pages, but I can't get any of them to appear with this theme)

    Ted

    Posted 2 years ago #
  2. Elliott
    Support

    Hello tedsmith,

    From what I understand your pages are not displaying in your menus correct?

    1. Make sure that they are actually published and not in draft mode.
    2. Make sure that they are not hidden.
    3. Try deactivating all of your plugins to see if they display. If they display then reactivate your plugins one by one to see which one was causing the conflict.
    4. Make sure that you have the correct menu selected to be used in Dashboard -> Appearance -> Menus. See here for more info, http://mysitemyway.com/docs/index.php?title=Using_Wordpress_Menus.

    If your still having issues then PM us a Wordpress login so we can take a closer look.

    Posted 2 years ago #
  3. "From what I understand your pages are not displaying in your menus correct?", Yes, though, specifically, I am unable to ADD pages to Menus via Dashboard, AND any Menu's I create do not show in this theme. The Pages I had created when using a previous theme (ProSlate) showed as menu's, though I don't think they actualy were menu's. So it's a two fold issue.

    I had already tried suggestions 1-3 as other people at Wordpress had suggested to do that.

    I have checked 4.

    I have PM'd you login details - if you can help, I would be hugely appreciative.

    Ted

    Posted 2 years ago #
  4. Elliott
    Support

    Your blog does not appear to have any pages tedsmith. I created one and added it to your menu and it displayed fine.

    Posted 2 years ago #
  5. Hi Elliot

    Many thanks, but...er, what's happened?

    I have just added another page too, and it is showing fine as well. But as you'll see in my 'Pages' section, there are 6 or 7 other pages that I created today and yesterday. a) Why don't they show and b) why are newly created one's now showing? Can you login again for me (please) and see if you can work out why they don't show? I'm not all that silly - I've not done anything different to what I've done before.

    Ted

    Posted 2 years ago #
  6. Elliott
    Support

    The only page I see is the one I created. It would probably be best if you did a backup and reinstalled Wordpress. Make sure that you install Wordpress manually, sometimes hosting providers like to change the code with their "one-click" installs.

    Posted 2 years ago #
  7. Elliot

    It's on my own dedicated server. It has been installed from scratch already.

    Are you saying you can only see the page "test" that you created? I have created a second page called 'Will this page show?" - I can see it. Can you not see it? And are you sayiong you didn't change anything to get that test page to show? I have spent two days trying to get them to show. I don't understand why you have just logged in, clicked on Pages, Add New Page, and it's appeared.

    Ted

    Posted 2 years ago #
  8. Elliott
    Support

    That's correct, it would probably be best if you created a backup and reinstalled Wordpress.

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme