Masive number of errors on on several if not all pages

open (16 posts) (5 voices)

  1. markgent
    Member

    Below is an an example of the number errors I'm getting on most of the pages on the site I'm webmaster for, in this example, for this page: http://www.thewla.org/blog/

    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/lib/functions/theme.php on line 1495

    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/loop.php on line 16

    Warning: Illegal string offset 'main_class' in /home/thewla/public_html/wp-content/themes/construct/loop.php on line 16

    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/lib/functions/theme.php on line 1446

    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/loop.php on line 20

    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/loop.php on line 23
    Warning: Illegal string offset 'post_class' in /home/thewla/public_html/wp-content/themes/construct/loop.php on line 25
    class="post-1422 post type-post status-private format-standard hentry category-blog">
    Warning: Illegal string offset 'blog_layout' in /home/thewla/public_html/wp-content/themes/construct/lib/functions/theme.php on line 1683

    Warning: Illegal string offset 'img_class' in /home/thewla/public_html/wp-content/themes/construct/lib/functions/theme.php on line 1711

    Posted 4 years ago #
  2. Elliott
    Support

    Hello markgent,

    Let's try the following,

    1. Deactivate all plugins.

    2. Create a backup and completely delete the theme before downloading / uploading a fresh copy.

    3. Create a copy of your theme settings in Dashboard -> your theme -> Advanced and then hit the "Reset All Options" button to see if they go away.

    Posted 4 years ago #
  3. markgent
    Member

    attached are some screen shots

    Attachments

    1. Screen-Shot-2013-10-30-at-11.58.35-PM..jpg (76.5 KB, 0 downloads) 4 years old
    2. Screen_Shot_2013-10-30_at_11.56.44_PM..png (99.2 KB, 0 downloads) 4 years old
    Posted 4 years ago #
  4. markgent
    Member

    so this is not because of the recent PHP updates?

    Posted 4 years ago #
  5. markgent
    Member

    how do i create a copy of my theme settings?

    Posted 4 years ago #
  6. markgent
    Member

    I talked to my host provider who told me something consistent with notices that I've been getting from other host providers...and that is, that there was some sort of update to PHP that was taking place and it happened last night. Is it not possible that the problem is related to this?

    Posted 4 years ago #
  7. Elliott
    Support

    You can create a copy of your theme settings in Dashboard -> your theme -> Advanced. Just copy all of the code in the export field.

    Posted 4 years ago #
  8. markgent
    Member

    I did everything you suggested above and it did not work. Not only that, but the theme settings that I imported did not restore everything the way the site looked before.

    PLEASE ADVISE ASAP?

    Posted 4 years ago #
  9. Elliott
    Support

    I don't know. So this started happening after your hosting provider updated PHP? Is Wordpress updated?

    Try creating a test directory and install a fresh copy of Wordpress and the theme there to see if it does the same.

    Posted 4 years ago #
  10. markgent
    Member

    Is it possible to escalate this to someone else on your team?

    Is it possible that the theme is conflicting with the newest PHP update?

    Posted 4 years ago #
  11. Elliott
    Support

    Send us a private message by clicking on the "PM this user" link beneath our usernames and include a Wordpress login + link back to this post.

    Posted 4 years ago #
  12. markgent
    Member

    private message sent

    Posted 4 years ago #
  13. ksgurm
    Member

    a public message showing resolution would be appreciated

    Posted 3 years ago #
  14. magician11
    Member

    I'm having the same issue.. and see no resolution.

    At the top of one of my posts I see

    "Warning: Illegal string offset 'caption' in /home/eastafri/public_html/wp-content/themes/awake/lib/shortcodes/18-images.php on line 167"

    I've disabled all plugins. I have debugging off in wpconfig.php I've reset the theme options and the issue persists. Any resolution on this that can be posted publicly? Or do I need to PM as well?

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme