Managing skin problem - kmercier

resolved (55 posts) (19 voices)

  1. kmercier
    Member

    Hi

    I'm using Wordpress 3.4.1 and Fusion 1.7 and when I edit the style sheet using Manage skin, all my colors change to black.

    Thanks

    Posted 5 years ago #
  2. Elliott
    Support

    Hello kmercier,

    Update your theme to the latest version and remove the color code from the custom background options in your skin and save.

    Posted 5 years ago #
  3. kmercier
    Member

    1) Where can I change the custom background color ?

    2) Everytime I create a page the background is black by default in the page options and I have a Bleu line on top of the page that become black when I scroll down.

    Thanks

    Posted 5 years ago #
  4. Elliott
    Support

    Looks like only half of the bug was fixed. Download the attached zip file and extract it to receive a "options-generator.php" file.

    You will need to upload this file into /wp-content/themes/[your_theme]/lib/admin/classes/ to overwrite the old one.

    Attachments

    1. option-generator.zip (10.2 KB, 368 downloads) 5 years old
    Posted 5 years ago #
  5. Elliott
    Support

    This is the custom background option, http://mysitemyway.com/docs/index.php?title=Post_Options#Custom_Background.

    You need to remove the color code from the field and save to get rid of the black. Do this in your skin and in any recent posts / pages you may have saved.

    Posted 5 years ago #
  6. jguthrie
    Member

    Hey mate. On 2.9 here. Cant see anywhere to download it from in my account? Purchased it from themeforest.

    Attachments

    1. inFocus.jpg (38.9 KB, 14 downloads) 5 years old
    Posted 5 years ago #
  7. Elliott
    Support

    You can purchase / download updates for inFocus and Awake from your themeforest downloads page.

    Posted 5 years ago #
  8. ammonlee
    Member

    The only thing I'm really trying to do is change the color scheme. I'm not doing a custom background color on a per page bases. I updated that option generator and that appears to partially fix the problem but I'm still getting several blue lines. Note: this is only when I change the color scheme and save as a new skin. The skin I am trying to change the color on is Panoramic. I tested doing this on translucence and it seems like it worked just fine.

    Posted 5 years ago #
  9. Elliott
    Support

    Send us a link to your page and take a screenshot highlighting what's going on.

    Posted 5 years ago #
  10. filipz
    Member

    I was just wondering whether you guys had any luck as I am experiencing exactly the same issue. I open black.css in the manage skins, give it another name and save as new skin and all boxes backgrounds change to black. Any fixes to that? Thanks

    Posted 5 years ago #
  11. Hi filipz,

    Have you updated your theme to latest version and tried common fixes Elliott suggests in other topics?

    []'s

    Posted 5 years ago #
  12. filipz
    Member

    Hi Rochester. I'm using 1.8, downloaded about 2 weeks ago so not sure. I found, however, that if, instead of clicking on the EDIT button, I click on the ADVANCED link (when in "manage skins" option) I can then save it with new name and apply it to my website with no problems so I am just going with that and play with CSS rather than using the controls.

    Posted 5 years ago #
  13. Apalm
    Member

    Hi I'm trying to fix this black problem too... switched out the options generator, still can't figure out where to change the custom background. Using Awake 3.0. Any suggestions?

    Posted 5 years ago #
  14. Elliott
    Support

    See here, http://mysitemyway.com/support/topic/managing-skin-problem-kmercier#post-80148.

    It is also used in the admin panel for the specialty pages tab.

    Posted 5 years ago #
  15. bignupe
    Member

    Elliott: Are you saying we have to go to every single page of our site and change the custom background for EACH PAGE?!? Is there no script that can clear the custom background?

    Posted 5 years ago #
  16. Elliott
    Support

    For each page that you have saved while using the latest version of Chrome. If it's happening on every page though then it's most likely the background option in your skin.

    Posted 5 years ago #
  17. IgniteDM
    Member

    This is NOT fixing the problem. I have uploaded the file you suggested above and I am still experiencing issues.

    I have a site that has NOT been edited using Chrome (and I'm 100% sure of this because I've had so many issues with other sites lately that I was so careful with this one). And no, I cant provide you the link because there is a coming soon page on the domain.

    As a test then, I uploaded that file listed above, then I just changed the font size through the skin editor and it removed the background style/image - and broke all manner of other things within the theme.

    If Chrome is such an issue, you need to have warnings across your site to let users know!

    Please help as I have a number of sites that I need to finish and I cant do this now that they cant be edited !!!!

    Posted 5 years ago #
  18. Elliott
    Support

    So your backgrounds are not turning to black? It may be something else then. It would help tremendously if I could see it in action.

    Try setting the following to 777 permissions,

    /wp-content/themes/[your_theme]/styles/

    And then create a new skin, edit it, and save to see if it works.

    Also be sure to deactivate all of your plugins while testing.

    Posted 5 years ago #
  19. beddarinn
    Member

    We have a problem with all of the pages we edit getting a new background with a black color instead of our background image. This also happens to our index/home page when we switch from and to the awake template.

    We have identified that when we edit a page, a new post_meta entry is created with "custom_background" and the following value : a:5:{s:3:"url";s:0:"";s:16:"background-color";s:7:"#000000";s:17:"background-repeat";s:6:"repeat";s:21:"background-attachment";s:6:"scroll";s:19:"background-position";s:8:"left top";}

    We have also identified that this codeblock is in the awake options in the table wp_options, although this setting can not be found in the awake options in the Wordpress Admin UI.

    We need to be able to switch between templates and edit pages without the background being changed.

    Posted 5 years ago #
  20. Elliott
    Support

    Update your theme to the latest version and do the quick fix provided in my second post.

    Posted 5 years ago #
  21. mkayes
    Member

    Thanks in advance for any help you can provide! I'm having this same issue with black appearing after saving a change in Chrome. I've ceased using Chrome to make edits but I cannot get the site to revert to how it was before I sued Chrome. I've tried replacing the stylesheets. The slider on the homepage..which I attached I cannot get rid of that black and I can't make the arrows go away. How it was before was it appeared without the arrows on the left and right and below it was 2 grey dots that you could click to advance to the next slider image. Now since it is black you cannot see these dots and any changes I make to the slider on the homepage do not go through. I've been using Firefox now and I will never use Chrome again to edit this theme. I would like the theme to go back to the way it should be. I'm using the Spa Skin for the Myriad theme. I cannot send you a link to the site as it has a coming soon page bc I don't want my client to see this appearing like it is now. The sooner you can provide a solution the better! Thanks you for your time.

    Attachments

    1. BlackButtonsandBlackBorder.jpg (17.5 KB, 2 downloads) 5 years old
    Posted 5 years ago #
  22. Elliott
    Support

    @mkayes, that's the responsive slider. You most likely set the theme to display on all devices instead of just mobile devices, http://mysitemyway.com/docs/index.php/Responsive_%26_Mobile#Responsive_layout_options.

    Posted 5 years ago #
  23. mkayes
    Member

    You are my hero! Thanks for your assistance and your timely response!

    Posted 5 years ago #
  24. xbandx68
    Member

    I Elliot, I have the same problem in my template MODULAR and ELEGANCE, I'm using WP 3.4.2 , when i try to change the color inside the skin , all picked color are BLACK!, I have to wait your de-Bug?
    thx

    Posted 5 years ago #
  25. Elliott
    Support

    See my second post for the fix, http://mysitemyway.com/support/topic/managing-skin-problem-kmercier#post-78252.

    Posted 5 years ago #
  26. Hayzie
    Member

    Hi team,
    I have tried the few fixes here and although it worked on one of the sites I'm using the Awake theme on, it hasn't with my main site.
    They are both running 3.0 but my main site (www.monkey3media.com) is using a 'Legacy Minimal White' skin/theme I downloaded from here, not sure if that's why the fixes won't work or if it's something else??
    I've left the site with the stuffed black backgrounds so you can see... hopefully you can find a fix for me?
    Thanks!

    Posted 5 years ago #
  27. Elliott
    Support

    You have to edit your skin and remove all of the color codes from the jQuery color pickers and save. There are lots of areas where the jQuery color pickers are used in the skin so make sure to remove them all.

    Posted 5 years ago #
  28. Hayzie
    Member

    Hey Elliott,
    Thought that might be the case and is easy to do within the page options (see attached image) because I have a colour code to delete. But in the Awake Skin editing section (see attached image) I only get a colour swatch which then only lets me select another colour?
    So, how do I get rid of the colour codes in this instance?
    Cheers,

    Attachments

    1. Awake_Skin_Options.JPG (55.2 KB, 5 downloads) 5 years old
    2. Awake_Page_Options.JPG (18.8 KB, 3 downloads) 5 years old
    Posted 5 years ago #
  29. Elliott
    Support

    You haven't done the fix yet. Read the whole thread.

    Posted 5 years ago #
  30. Hayzie
    Member

    My bad, sorry about that... looks like I've got it now.
    Thanks!

    Posted 5 years ago #
  31. mmswan
    Member

    I uploaded the option-generator where indicated, but I don't understand the rest and I'm on the verge of launching. So, if I don't work in Google chrome I can avoid this problem in the future? I tried downloading the grunge skin again for Construct, but it's still the same black. Sorry, but I just don't know what to do next: guruswan.com/atc

    Posted 5 years ago #
  32. mmswan
    Member

    This is the same post thread on right here. I'm lost as to the where to remove the custom background. Is there a way to simply restore the original skin?

    Does this problem exist only while working in Google Chrome?

    Posted 5 years ago #
  33. Elliott
    Support

    Yes only in Google Chrome. You have to upload the options-generator.php file to overwrite the old one and then remove the color code from all the jQuery color pickers in your skin and any recent posts / pages you may have saved.

    It's all explained in the beginning of this thread.

    Posted 5 years ago #
  34. mmswan
    Member

    I'm sorry, I did upload the options-generator.php file but I don't know how to go about removing the color code from all the jQuery color pickers. Is there any way to just start over such as deleting the theme and then re-uploading, since I don't understand the process? I don't have any posts, just portfolios - is it the same?

    Posted 5 years ago #
  35. mmswan
    Member

    I have looked in the grunge skin after over-writing the options-generator.php per instructions, above. There is NO CUSTOM BACKGROUND option anywhere in that skin, as per your third post.

    Posted 5 years ago #
  36. Elliott
    Support

    Send us a private message by clicking on the "PM this user" link beneath our usernames and include a link to your site, a Wordpress login, and a quick description of the problem.

    Posted 5 years ago #
  37. Thanks for the fix - works ok.

    However, when I list blog posts of a particular category (from the menu) I get a 'category archive' listing - which still has the black background.

    How do I edit the background colour for this page? It's not something I have created, so I don't know how to access it.

    Thanks, Mike

    Posted 5 years ago #
  38. Scrub that request, I found out myself.

    Dashboard > [theme] > Speciality Pages > Archives

    Removed #000000 from custom background colour

    Thanks.

    Posted 5 years ago #
  39. Ok, then.

    Thanks for sharing it!

    []'s

    Posted 5 years ago #
  40. thecounsellor
    Member

    I use Google - got same response

    Found that if I did an advanced edit it did not give me the problem - so just go straight there instead of the edit button

    Barry

    Posted 5 years ago #
  41. xtig3r
    Member

    Thanks Elliott, the fix fixed it!

    Posted 5 years ago #
  42. LisaRoth
    Member

    I'm trying to change the color (colour) of the h3 Font under General Typography in Awake, but having no luck. I can change h4 and h5, but really I want to leave them as they are and change h3. I was able to reduce the size of h3, but not the color.

    Is the h3 color tied to something else? In the Steelblue skin the h3 Font color is #444.

    What am I missing?
    Thanks a million!
    Lisa

    I'm using the most current version of WP and Awake.

    Posted 5 years ago #
  43. Elliott
    Support

    Send us a link to your page and take a screenshot highlighting the area your wanting to change.

    Since your using Awake you may need to take the gradients off first, http://mysitemyway.com/docs/index.php/Awake_Cufon_colors.

    Posted 5 years ago #
  44. LisaRoth
    Member

    Hi Elliott,

    Thanks for the super quick reply. Here's a page showing some h3 heads
    http://www.ucsf-ahp.org/ALLIANCE-WP-site_3-4-2012/hi/hcat/

    I'm attaching a screenshot showing the h3 heads in gray and the h4 in orange. If I could get the h3 to be orange, I'd leave everything else gray.

    thanks for all!
    Lisa

    Posted 5 years ago #

Reply »

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme