inFocus: Creating "Gallery" from a set of Photos

resolved (87 posts) (18 voices)

  1. Elliott
    Support

    Here is an update which includes video. You would put the URL to your video in the url parameter for each image. If you do not specify a video URL then it will join the rest of your images inside prettyPhoto.

    [fancy_images url = ',http://www.vimeo.com/235623,,,']
    URL TO IMAGE 1
    URL TO IMAGE 2
    URL TO IMAGE 3
    URL TO IMAGE 4
    URL TO IMAGE 5
    [/fancy_images]

    In the above example all of the images will open in a gallery inside prettyPhoto except for the second one which will open up to display a vimeo.

    Attachments

    1. fancy_images_with_video.zip (2.4 KB, 33 downloads) 3 years old
    Posted 3 years ago #
  2. Stoyan
    Member

    Hi Elliott,

    Just a note for span tag ID that holds the image. In the current code where it says

    <span id="img1">

    it's not valid, because out duplicated ID. Maybe it should be

    <span id="img' .$counter. '">

    or something.

    Cheers!

    Posted 3 years ago #
  3. Elliott
    Support

    Good catch Stoyan, shortcode updated.

    Posted 3 years ago #
  4. xerond
    Member

    Hey I have a question about how to specify the thumbnail and fullsize image within the fancy images shortcode.

    It seems when I place a fullsize image within the shortcode (945X516) it doesn't create a thumbnail. It does display the fullsize within the lightbox nicely. And if I use a thumbnail size image instead(276x151) it does display with the thumbnail image, but..obviously only displays the thumbnail within the fullsize lightbox. How do I properly list both sizes within the shortcode?

    Another possibility that I'm interested in, is to create a single thumbnail that when clicked will bring up the lightbox, and then have several fullsize images that you can switch between within the lightbox, without having to display all the thumbnails on the page. For example I want to place a single thumbnail, that contains one angle of a construction job site, but when you go fullsize you can see multiple fullsize images of the same job. The user would not be able to see the fullsize images otherwise.

    And to top it off, is it possible to have multiple thumbnails on the same page, in the same row with the above functionality?

    Posted 3 years ago #
  5. Elliott
    Support

    Hello xerond,

    There is currently not a "full" style with the shortcode. We are working on a new framework which should be completed very soon so it would be best to go ahead and wait for it.

    As for the second question you would need to put some more links in your content like this,

    <a href = 'IMAGE URL' rel = 'prettyPhoto[portfolio]' style = 'display: none;'>image1</a>

    prettyPhoto should pick them up and add them to the gallery.

    Posted 3 years ago #
  6. jrnielsen7
    Member

    I have been following this post. Love this theme! I have updated the shortcode.php. Here's the problem, when I insert an image link between [fancy_images] [/fancy_images] tags, the image comes up twice.

    Here's the link to what I am talking about:
    http://02bc688.netsolhost.com/wordpress/?page_id=69

    Any help would be appreciated.

    Posted 3 years ago #
  7. Elliott
    Support

    Hello jrnielsen7,

    Make sure that you are using the latest updated shortcode here, http://mysitemyway.com/support/topic/infocus-creating-gallery-from-a-set-of-photos

    Go ahead and paste the code that you used for that page and let us know which template you are using.

    Posted 3 years ago #
  8. jrnielsen7
    Member

    I made sure to download the latest shortcode from this thread. I am using your inFocus theme. Here is exactly what I placed in the editor.

    [fancy_images]
    http://02bc688.netsolhost.com/wordpress/wp-content/uploads/2011/02/image3.jpg
    http://02bc688.netsolhost.com/wordpress/wp-content/uploads/2011/02/image21.jpg
    [/fancy_images]

    I still receive the double images for both. Any thoughts? Could it be something I am doing wrong?

    Here is the link again:
    http://02bc688.netsolhost.com/wordpress/?page_id=69

    Posted 3 years ago #
  9. Elliott
    Support

    Which template are you using jrnielsen7? And is the shortcode the only thing that you are displaying on that page?

    Go ahead and PM us WP Login information so we can take a closer look.

    Posted 3 years ago #
  10. jrnielsen7
    Member

    Thanks Elliott. I just sent you a PM with all the information you requested.

    Posted 3 years ago #
  11. Elliott
    Support

    Hello jrnielsen7,

    When placing your image URL's make sure to just place the URL and no other markup. You currently have your URL's surrounded by links. I went ahead and removed the extra markup for you so go check out the page to see how it is done.

    Posted 3 years ago #
  12. jrnielsen7
    Member

    Perfect! Thanks for your time and patience Elliott.

    Posted 3 years ago #
  13. Sorry but I'm a bit confused: I see here multiple shortcode files with updates but I don't know which is the most recent one and whether or not the updated version has video included. Is 'fancy_images_with_video.zip" the latest version with the updated shortcodes from the previous page?

    Posted 3 years ago #
  14. Elliott
    Support

    Hello keller2323,

    You can get the most recently updated one in my first post on this thread. If you need video then you can try the video version but it does not have as much functionality as the updated one.

    We will be adding this functionality in our next update which is coming very soon.

    Posted 3 years ago #
  15. I've been wondering if there is a way to align the pictures center? Using WYSIWYG for that doesn't work. In addition, resizing looks like an issue. If I want to have 3 pictures in a row, usually the third picture is cut off. Do you plan to implement automatic resizing in the future so that Wordpress/Theme will automatically resize thumbnails so that they will all fit?

    Posted 3 years ago #
  16. Elliott
    Support

    Hello keller2323,

    If your using the full-width template then you should be able to get 3 images in a row. Make sure that you are not using the sidebar = 'yes' parameter.

    In regards to automatic resizing inFocus uses a fixed width because of the image frames. With the Awake image frames you can resize the width and height to however you want. If you really need them a certain width / height then you will need to edit the image frames also.

    I'm not sure if this will be a feature in the next update or not, I'll have to check with the devs. If it isn't updated when the new framework rolls out then we will probably get a quick fix going.

    Posted 3 years ago #
  17. dotman
    Member

    I can't get the captions to show in the light box. Here's what I have. I've also tried full urls to the image in the opening tag with no luck as well. and BTW, is the video support integrated into the last updated zip, or does one have to choose between the two?:

    [fancy_images sidebar = 'yes' title = 'kitchen-full.jpg,kitchen3_full.jpg,kitchen2_full.jpg,This is a caption,And here is another,and the last caption']

    http://localhost/jerore/wp-content/uploads/2010/08/kitchen-full.jpg

    http://localhost/jerore/wp-content/uploads/2011/03/kitchen3_full.jpg

    http://localhost/jerore/wp-content/uploads/2011/03/kitchen2_full.jpg
    [/fancy_images]

    Also, If i use the [fancy_images] shortcode INSTEAD of the [gallery] shortcode, the lightbox does not pick up the additional images on the Portfolio page. Do i have to choose between the two. i thought the lightbox would pick up the fancy images as well on the portfolio. How can I do this?

    Thanks,
    Doug

    Posted 3 years ago #
  18. Elliott
    Support

    Hello dotman,

    You would need to choose between the two for now. This will be fixed in our next update, sorry for the inconvenience.

    As for the captions I noticed you are using three images and six captions, try this,

    [fancy_images sidebar = 'yes' title = 'Caption 1, Caption 2, Caption 3']

    As for the portfolio page not picking up images, open up the shortcode.php file and on line 46 you should see this,

    $link = ($custom_link) ? ' href="' .$custom_link. '"' .$target : ' rel="lightbox[small_gallery]" href="' .$img. '"';

    Try changing it like this,

    $link = ($custom_link) ? ' href="' .$custom_link. '"' .$target : ' rel="lightbox[portfolio]" href="' .$img. '"';

    Let us know if that works for you dotman.

    Posted 3 years ago #
  19. dotman
    Member

    Thanks. That fixed the captions, but the portfolio is still not picking up the extra images. Also, does this mean that once this is working, if the gallery shortcode is used on a different post, I'll have the same problem? Just wondering if I'm restricted to one or the other for the portfolio to pick up the extra/attached images. Really looking forward to the new version. when will that be out?

    Thanks,
    Doug

    Posted 3 years ago #
  20. Elliott
    Support

    Hello dotman,

    If possible then send us a link to your page so we can take a closer look. As for the next update see this thread, http://mysitemyway.com/support/topic/launch-update

    Posted 3 years ago #
  21. dotman
    Member

    Hey elliot, right now it's being developed locally using mamp. are there specific files i can provide for you? Other code you would like me to try? I suppose I could zip the theme folder and upload it if that would be helpful

    Thanks,
    Doug

    Posted 3 years ago #
  22. Elliott
    Support

    It is hard to tell without a link to your site. Go ahead and post the full code you are using for that portfolio page.

    Posted 3 years ago #
  23. dotman
    Member

    ok, I got it uploaded. You'll see in this post I have three images using the fancy images shortcode:

    http://homecabinetryandinteriors.com/portfolio/classic-columns/

    And the post appears in the portfolio here:

    http://homecabinetryandinteriors.com/picture-gallery/kitchens/

    When the image is clicked, you'll see it's not pulling the images from the fancy images shortcode.

    Also, just noticed this. It only occurs on the page referenced above, and only on a page it seems that has the fancy images shortcode. the layout is completely out of whack in Safari 5.0.3:
    http://homecabinetryandinteriors.com/portfolio/classic-columns/

    Thanks,
    Doug

    Posted 3 years ago #
  24. Elliott
    Support

    It looks like your page layout is broken in chrome. This is most likely due to some elements that were not closed properly. Paste the code that you used here so we can take a closer look.

    As for that specific image you will need to open up /wp-content/themes/infocus/lib/includes/template-single.php and on line 200 you should see this,

    <a class="load_blog_img" rel="lightbox" title="<?php the_title(); ?>" href="<?php echo $portfolio_link; ?>">

    Try changing it like this,

    <a class="load_blog_img" rel="lightbox[portfolio]" title="<?php the_title(); ?>" href="<?php echo $portfolio_link; ?>">

    Posted 3 years ago #
  25. dotman
    Member

    Hey Elliot,
    I changed the line int the single-template, but the post in the portfolio still isn't grabbing the 3 images in the light box. if you want to login and take a look, happy to pm you the credentials.

    Here's the code for that post that has the bad formatting. Looks fine in FF, but as you said, a mess in Chrome and Safari:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Maecenas rutrum, nisi quis placerat mollis, neque nisl semper lacus, sit amet suscipit elit ante adipiscing sem. Proin feugiat mauris nec nulla pellentesque id rutrum nibh rutrum. Donec porta massa a neque cursus condimentum. Duis blandit condimentum quam, eget interdum libero mollis ac. Sed vestibulum libero in ligula egestas aliquet. Pellentesque et elit et est porttitor semper. Nulla risus augue, aliquam sed ullamcorper eget, semper condimentum libero. Ut ornare, mauris a ullamcorper ullamcorper, risus nisi sagittis orci, non aliquam magna metus id lacus. Maecenas auctor interdum tristique. Mauris mattis magna et diam suscipit et mattis arcu condimentum. Aliquam erat volutpat.

    Suspendisse potenti. Fusce tristique ultrices enim et convallis. Donec quis tellus pharetra mi faucibus tincidunt vitae sit amet neque. Mauris sit amet magna ut arcu volutpat tristique. Aliquam faucibus dignissim venenatis. Etiam placerat pretium risus gravida dapibus. Morbi leo massa, tincidunt quis venenatis id, placerat sed risus. Proin rhoncus sollicitudin eros, a aliquet ipsum dignissim et. Sed a magna vel leo euismod fringilla. Nulla facilisi. Integer sit amet risus vel mauris sagittis porta a eget purus. Donec tempor egestas elementum. Vivamus lobortis egestas molestie.

    [fancy_images sidebar = 'yes' title = 'This is a caption, This is anothe caption, and the very last caption that is a little longer so we can see if it will fit.']

    http://homecabinetryandinteriors.com/wp-content/uploads/2010/08/kitchen-full.jpg

    http://homecabinetryandinteriors.com/wp-content/uploads/2011/03/kitchen3_full.jpg

    http://homecabinetryandinteriors.com/wp-content/uploads/2011/03/kitchen2_full.jpg
    [/fancy_images]

    Posted 3 years ago #
  26. Elliott
    Support

    It seems to be working on my end dotman. Try clearing your browser cache.

    Nothing looks wrong with your page code, I think you probably messed up your shortcode.php file when you were editing it. Try redownloading a fresh copy in the beginning of this thread to see if this fixes it.

    Posted 3 years ago #
  27. dotman
    Member

    Hey Elliot,

    When you say "working" do you mean that when you are on the portfolio page here:

    http://homecabinetryandinteriors.com/picture-gallery/kitchens/

    and you click on the image (not the read more. i know I can see the additional images in lightbox when at the post), you are seeing all three images in the lightbox? Becasue i am not.

    I've re-downloaded the shortcode.php file from the bottom of page 1 of this thread (thought that was most recent one) and added the new code at line 46 as mentioned above.

    Still isn't working and the format is still messed up.

    I'm attaching my shortcode.php file so you can check it. Again, if you need to ftp in to resolve this, not a problem.

    Thanks,
    Doug

    Edit: looks like my zip file was denied. How would you like me to get you the code. i tried surrounding it with the
    pre lang tag with no luck.

    Posted 3 years ago #
  28. Elliott
    Support

    Go ahead and PM me Wordpress login information so I can take a closer look at your code dotman.

    Posted 3 years ago #
  29. dotman
    Member

    Hey Elliot, you should have it.

    Thanks,
    Doug

    Posted 3 years ago #
  30. Elliott
    Support

    For some reason you have <code> brackets surrounding your shortcode. Switch to the HTML editor and take those off to see if this fixes it.

    Posted 3 years ago #
  31. g-saint
    Member

    How do you get the thumbnails to appear within the lightbox, just like dotman's website? I've downloaded the latest version shortcode.pho, but they don't come up automatically. Are they meant to? Here's what I'm using:

    [fancy_images]
    http://www.mysite.com/image1.jpg
    http://www.mysite.com/image2.jpg
    http://www.mysite.com/image3.jpg
    [/fancy_images]

    Also, what's the best way to create a series of galleries? For example:
    Photo Gallery (page)
    - Computers (gallery 1)
    - Televisions (gallery 2)
    - Phones (gallery 3)

    Should I create separate pages for each gallery (Computers, Televisions, etc.) and then manually add another "gallery" in Photo Gallery that will link to those galleries? Any way to dynamically do this? Or a better way of doing it?

    Posted 3 years ago #
  32. gvandeveer
    Member

    I can see the pic as a thumbnail but lightbox is not opening anything, just a "ticker" waiting to open something.

    Posted 3 years ago #
  33. gvandeveer
    Member

    im getting this error

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.6; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.3)
    Timestamp: Tue, 12 Apr 2011 13:44:18 UTC

    Message: 'undefined' is null or not an object
    Line: 55
    Char: 32
    Code: 0
    URI: http://mysite/wp-content/themes/infocus/lib/scripts/prettyPhoto/js/jquery.prettyPhoto.js?ver=3.1.1

    Posted 3 years ago #
  34. Elliott
    Support

    Hello g-saint,

    If possible send us a link to your site so we can take a closer look.

    @gvandeveer, Try updating prettyPhoto to the latest version. See here for more details, http://mysitemyway.com/support/topic/infocus-and-wordpress-31

    Posted 3 years ago #
  35. gvandeveer
    Member

    You are a stud! Thank You Elliot

    Posted 3 years ago #
  36. mhexter
    Member

    Elliot,

    I would like to add a caption under my image and I think I must be missing something. Here is the code I am using, which currently displays the image [brilliant!] but does not display the caption.

    What am I missing?

    [fancy_images title = 'ScreenShot006.jpg,Hickory Saddle']
    http://valleyflooringllc.com/wordpress/wp-content/uploads/2011/06/ScreenShot006.jpg
    [/fancy_images]

    BTW, I did update my shortcodes, but it looks like there have been numerous iterations posted. Perhaps I'm using the wrong shortcode file?

    Posted 2 years ago #
  37. Elliott
    Support

    Hello mhexter,

    Make sure to use the updated shortcode on this page, http://mysitemyway.com/support/topic/infocus-creating-gallery-from-a-set-of-photos#post-7611

    If your still having problems then if possible PM us a Wordpress login so we can take a closer look.

    Posted 2 years ago #
  38. samdelagarza
    Member

    I've followed the instructions as best as I can, but here's the result of my portfolio thus far.

    https://skitch.com/samdelagarza/fexxw/portfolio-limpieza-de-cristales-pco

    Guidance would be appreciated. I'm using WP 3.2

    Posted 2 years ago #
  39. Elliott
    Support

    Hello samdelagarza,

    Try the fix here, http://mysitemyway.com/support/topic/awake-theme-portfolio-page-not-working-after-upgrade-wordpress-to-32. If that doe snot help then send us a link to your site so we can take a closer look.

    Posted 2 years ago #
  40. Hi,

    3 Questions:

    1) How do I prevent the featured image on a portfolio to be clickable?

    2)What is the Portfolio category for in normal posts.
    Can it also be used to create portfolio image galleries as I'm only able to do that via making new portfolios now?

    IE: If I ever want to post a list of say 12 images directly on my blog, but I also want these images to show up on
    a portfolio page, how do I go about this?

    I've read every topic I could find but can't find an answer to the above.

    3)How do I mix in fancy images border shortcodes with a fancy images array/list?

    Thanks in advance for your assistance!

    Posted 1 year ago #
  41. Elliott
    Support

    @Byzantos, Create a new forum topic please.

    Posted 1 year ago #
  42. Excellent. That's more then one can hope for after waiting the day for a bit of help.
    Done. Posts created.

    Posted 1 year ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme