Infocus corruption?

resolved (10 posts) (2 voices)

  1. Hi,

    Was just updating a few pages on my site recently.
    When I checked the site afterwards, only one page would load not including the home page.
    I went back into wordpress, but couldn't find anything obvious.

    Next step was to switch to the standard 2014 theme, and that works fine.
    I then deleted the infocus theme, and reinstalled it with a new download from your servers.
    But I still get the same problem - in fact infocus won't even preview in the themes tab.

    Is it possible that infocus can be corrupted but wordpress works ok?
    Any ideas how to resolve this?

    Posted 3 years ago #
  2. Managed to get the infocus theme working again after deleting a post using the galleria shortcode.
    Also reassigned the css colour theme - probably necessary after deleting and reinstalling the theme previously.
    Have now undeleted the post using galleria and it seems to be working so far.

    Question is:
    Is this problem due to the fact that I cannot use timthumb (image resizing tab) ?
    I either get blank images in the slider if I enable it, or get the following error:

    Image not found: http://www.holtcivils.com/wp-content/themes/infocus/lib/scripts/timthumb/thumb.php?src=http://www.holtcivils.com/wp-content/uploads/2013/12/IMG_4047.jpg&w=672&h=1000&zc=1&q=100

    If so, how do I get that to work?

    Posted 3 years ago #
  3. Elliott
    Support

    Hello holtphotouk,

    Try setting the following to 777 permissions,

    /wp-content/themes/[your_theme]/cache/
    /wp-content/themes/[your_theme]/lib/scripts/timthumb/thumb.php
    Posted 3 years ago #
  4. Hi Elliot,

    Thanks for the quick reply.

    The cache seems sorted (fingers crossed) - no hiccups as yet. Big thanks for that.
    The timthumb doesn't work, so I have kept that as a wordpress resize.

    Do you think this is related to the sidebar not working in the blog?
    It's got the shading but not the entries:
    http://www.holtcivils.com/cad-blog-2/

    Posted 3 years ago #
  5. Elliott
    Support

    Try deleting your .htaccess file and then refresh your permalinks in Dashboard -> your theme -> Permalinks.

    Posted 3 years ago #
  6. Back to square one and worse now, I'm afraid.
    But now I can't get infocus to load, even after deleting the pages with galleria shortcodes.

    Deleting the .htaccess seemed to stop the infocus pages loading completely.
    WP seems to have rebuilt it, but now I can't preview infocus at all.
    It's fine using the base theme, 2014.

    I have deleted infocus completely, re-uploaded it and tried to activate it, but I'm not getting any preview.
    If activate, I get a hanging home page: Screen shot of activated home screen attached.

    Are these extended problems due to a linux versus windows server?!

    Attachments

    1. Untitled-1.jpg (51.7 KB, 0 downloads) 3 years old
    Posted 3 years ago #
  7. Elliott
    Support

    I tried viewing your link again but I get a 404. Try reinstalling Windows and delete all plugins.

    Posted 3 years ago #
  8. I believe it's a linux server in truth, but it's a shared resource so I can't reinstall anything.
    I left it overnight and for some reason I was able to preview it and activate then.
    Maybe the host company Easily.co.uk is preventing certain routines?
    I'll have a word with them and let you know.

    The blog page now looks like this also...

    Attachments

    1. Untitled-2.jpg (118.5 KB, 0 downloads) 3 years old
    Posted 3 years ago #
  9. Elliot, this is now solved.

    Steps followed:
    1. Export of the current wordpress site as xml to my desktop
    2. Comment out chmods in the php.ini as per: "; disable_functions = chmod"
    3. Delete entire WP site including infocus theme
    4. Upload fresh WP (ie downloaded from their site today) with infocus theme already in the wp-content theme folder.
    5. Install WP - new database used for this btw.
    6. Activate infocus
    7. Import site from xml file.

    I'm not great at this kind of stuff, but it might be the php.ini not being correct at first installation of infocus not allowing it all to work properly.

    Nightmare eh!

    Many thanks for the hard work designing it all at your end.

    Posted 3 years ago #
  10. Elliott
    Support

    I recommend installing Wordpress manually instead of using a copy that the hosting provider offers. They will sometimes change some of the code which causes problems.

    Posted 3 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme