Header background disappeared

resolved (11 posts) (2 voices)

  1. Nicola-uj
    Member

    I logged into my site today and my header background has disappeared.

    I have a custom header background, a gradient that goes behind the logo. I have it entered in the General Settings Custom CSS as follows:

    #header{position:relative;height:170px;background:url(http://granitereworks.com/gwwordpress/wp-content/uploads/2013/06/header.png) repeat-x; center-top;}

    I have gone into the style.css and entered as follows:
    #header{position:relative;height:170px;background:url(http://granitereworks.com/wp-content/uploads/2013/06/header.png) repeat-x center top;}, then uploaded it to wordpress via ftp.

    I also have it uploaded in the skins as the header background.

    I have checked that the url is current and correct.

    Then I actually replaced the original header.png file in the theme files with my custom gradient, keeping the name header.png. So even if it tries pulling the header from themes>infocus>images, the custom gradient is there as well.

    Any ideas to why it is not appearing? I must be missing something!
    I don't have any plug-ins activated.

    Thank you.
    http://granitereworks.com

    Posted 4 years ago #
  2. Elliott
    Support

    Hello Nicola-uj,

    The image your using is giving me a 404, http://granitereworks.com/gwwordpress/wp-content/uploads/2013/06/header.png.

    Posted 4 years ago #
  3. Nicola-uj
    Member

    Hi Elliott,
    That is weird, because I do see it in the Media Library. But I also get an error message if I put it in my browser.
    So, I uploaded to the Library again, and I can see it in my browser now:
    http://granitereworks.com/wp-content/uploads/2013/06/header1.png

    Again, replaced that in General Settings>Custom CSS
    style.css
    skins

    Still no luck. I am not very versed in php - could there be a script or something that went haywire that pulls the header?

    Posted 4 years ago #
  4. Elliott
    Support

    Are you using a caching plugin? I'm still seeing it as, http://granitereworks.com/gwwordpress/wp-content/uploads/2013/06/header.png

    Posted 4 years ago #
  5. Nicola-uj
    Member

    I used Firebug, and I see as well that the old header image is still there. I don't know why.
    I am not using any plugins at all for this site.
    I have been on tech support with GoDaddy, just in case it is a server issue, or something not caching there. They can't find anything wrong. I also tried switching to another template, and uploading a header. That responds, so it looks like the server end is working.

    It is something with just the header. I am able to change the template to a different wordpress template, I can change the logo, I can change the text - all with an immediate response after the save. If I try making any header change - even just choosing a new header image in the skin and saving, there is no change.

    Sorry to be such a pain; I can't imagine what I did here.

    Posted 4 years ago #
  6. Nicola-uj
    Member

    I have still been working on this. I Deleted all images so that all pages came up with no header.
    Re-uploaded the image and called it header.png.
    Went page by page and plugged in the custom css.
    When I Updated, the header appeared correctly on every page except home and the blog page -- full article version.
    (blog is "News & Events Page", and News & Events comes up with the correct header. Only when you go to Read More, header is not there.)

    Posted 4 years ago #
  7. Elliott
    Support

    You shouldn't have to use any CSS for it to work. Go ahead and remove any customizations you have done.

    Posted 4 years ago #
  8. Nicola-uj
    Member

    Ok, I have removed all Custom CSS from General Settings.
    Still no header background.

    Posted 4 years ago #
  9. Elliott
    Support

    Try creating a backup and completely delete the theme before downloading / uploading a fresh copy.

    Posted 4 years ago #
  10. Nicola-uj
    Member

    Oh, darn, that was my next guess. I will do that.

    Thanks for your time in reviewing this.

    Posted 4 years ago #
  11. Nicola-uj
    Member

    Elliott,
    Just my final notes on this. I think that I must have had overlapping CSS plugged in at different locations.
    I deleted the template, uploaded a fresh copy and began again.
    Everything is working as it should.
    Thanks again.

    Posted 4 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme