Full Screen Video On Page Load?

(20 posts) (3 voices)

  1. I've been asked by my client to see if they can have a 15 second video load and play in full screen (or close) then redirect to Echelon Home Page. And include a skip this video button.

    I realize this is a customization and not a theme feature, but perhaps you can point me in the right direction or have an idea on where to look to do this. I've spent time searching and haven't come up wiht anything.

    I appreciate anyone's thoughts.

    I guess alternatively, I can have the VIMEO autoplay in the SLIDER, but it will start sliding before end of video ?

    thanks,

    Posted 5 years ago #
  2. Elliott
    Support

    Hello MacMyDay,

    I would check out the prettyPhoto examples, http://www.no-margin-for-errors.com/projects/prettyphoto-jquery-lightbox-clone/.

    You can also try setting the vimeo to autoplay in the slideshow.

    Posted 5 years ago #
  3. Hi Elliott -

    I saw the auto play setting on slide show and was wondering if after video is over will the slider advnace to next slide?

    And by changing core.php all videos in the slider will auto play? Will they start playing on page load or when the slider changes to that slide containing the video?

    Finally, must I have on face or will it work with sliding effect on the slider?

    Posted 5 years ago #
  4. Elliott
    Support

    I believe when the video loads it will autoplay so when the next slide comes up it should autoplay, go ahead and try it. I'm not sure what you mean by face.

    Posted 5 years ago #
  5. Okay. it's now loaded and changed to core.php on my dev server here: http://bit.ly/QgyZl4

    Here are the problems I need to solve:

    1) The video plays and ends, but doesn't advance to the next slide.

    2) There is a second video in Slide 4 that begins playing and two audio tracks are stepping on each other on page load.

    Anyway to hold auto play of second video?

    Posted 5 years ago #
  6. Elliott
    Support

    I tried viewing your link but the slideshow isn't loading at all.

    Posted 5 years ago #
  7. Can you try again? Because it is loading for me. Maybe I was playing with the vimeo embedding when you tried? It whould be working! This is a critical piece to client site. thanks!

    Posted 5 years ago #
  8. Elliott
    Support

    Are you sure you don't have automatic transitioning disabled? Your normal slides are not advancing.

    Is the audio playing double when you advance the slides manually?

    Posted 5 years ago #
  9. Yes. When I advance manually using nav dots, the audio from both videos continues to play.

    I do not have auto transitioning disabled.

    Posted 5 years ago #
  10. FYI.

    For the launch of this site, I've taken out the 2nd video from the slider, tho the client would like it in.

    Paramount is the fact that the slider doesn't advance through the slides after the initial video plays. There is no mouse hovering, the slider is just static and does nothing after playing the video.

    We need the slider to advance through the next four slides after playing that video.

    Any ideas?

    Posted 5 years ago #
  11. Elliott
    Support

    Open up /wp-content/themes/[your_theme]/lib/scripts/custom.js and around lines 271 - 290 you should see this,

    VimeoEmbed.vimeo_player_loaded = function(player_id) {
    	VimeoEmbed.setupAPIEventListeners(player_id);
    };
    
    VimeoEmbed.setupAPIEventListeners = function(target) {
    	iframe_player = document.getElementById(target);
    	iframe_player.addEvent( 'onPlay', VimeoEmbed.vimeo_on_play);
    };
    
    VimeoEmbed.vimeo_on_play = function(player_id) {
        if( jQuery('#mysite_scrolling_slider').length>0){
    		jQuery('#mysite_scrolling_slider').data('scrollable').stop();
    		jQuery('#slider_module_inner').mouseout(function() {
    			jQuery('#mysite_scrolling_slider').data('scrollable').stop();
    		});
    	}
    	if( jQuery('#fading_slides').length>0){
    		jQuery('.slider_nav').data('slideshow').stop();
    	}
    };

    Try changing it to this,

    VimeoEmbed.vimeo_player_loaded = function(player_id) {
    	VimeoEmbed.setupAPIEventListeners(player_id);
    };
    
    VimeoEmbed.setupAPIEventListeners = function(target) {
    	iframe_player = document.getElementById(target);
    	iframe_player.addEvent( 'onPlay', VimeoEmbed.vimeo_on_play);
    	iframe_player.addEvent( 'finish', VimeoEmbed.vimeo_on_end);
    };
    
    VimeoEmbed.vimeo_on_end = function(player_id) {
    	jQuery('#mysite_scrolling_slider').data('scrollable').next();
    	jQuery('.slider_nav').data('slideshow').next();
    };
    
    VimeoEmbed.vimeo_on_play = function(player_id) {
        if( jQuery('#mysite_scrolling_slider').length>0){
    		jQuery('#mysite_scrolling_slider').data('scrollable').stop();
    		jQuery('#slider_module_inner').mouseout(function() {
    			jQuery('#mysite_scrolling_slider').data('scrollable').stop();
    		});
    	}
    	if( jQuery('#fading_slides').length>0){
    		jQuery('.slider_nav').data('slideshow').stop();
    	}
    };
    Posted 5 years ago #
  12. Okay. I've added this code, but I think the behavior I'm reporting here existed even prior to changing the code. In short, I'm not sure this new snipped did anything.

    Here's the issue now:

    1) The video is set for manual play; I've got transition speed set for the duration of the first video. However there is a second video that is longer.

    Can we set this so that the slider stops transitioning until either the video finishes playing or the user clicks a dot.

    2) The slides moves fast skipping a slide and going to the slide after.

    3) If the user changes a slide the video still plays in the background. As noted, we would like the video to play until end and then continue slide show; or if user decides to click a nav dot then the video stops playing a slideshow resumes.

    Check this out:

    http://screencast.com/t/9TpEYHXy

    Posted 5 years ago #
  13. Elliott
    Support

    Send us a link to your page. In your previous link Wordpress is having trouble establishing a database connection.

    Posted 5 years ago #
  14. Hmmm. Maybe staging server, here's a good link:

    http://bit.ly/11tzoau

    Posted 5 years ago #
  15. Okay. This is the correct link.

    http://bit.ly/11tzoau

    And this screencast shows the behavior: http://screencast.com/t/9TpEYHXy

    My objective is:
    1) Eliminate the fast skipping as evidenced in screencast.

    3)Have the videos in the slideshow (there are two) play until end and then continue slide show; when or if a user decides to click a nav dot then the video stops playing a slideshow resumes.

    Posted 5 years ago #
  16. Elliott
    Support

    1. We'll look into getting a workaround / fix in a future update.

    2. I don't think we have any youtube / vimeo controls for the flex slider but we'll be looking into adding some in a future update.

    Posted 5 years ago #
  17. Okay. So meanwhile, not much I can do?

    Even if I disable the auto transition of slides, I still get the video playing over the other slides.

    Posted 5 years ago #
  18. Elliott
    Support

    We'll look into it.

    Posted 5 years ago #
  19. thanks,

    Posted 5 years ago #
  20. omg
    Member

    Simple answer: Slider Revolution plugin for $12 from Code Canyon

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme