Featured Image

resolved (16 posts) (2 voices)

  1. branditsocially
    Member

    Hello. I am using the Awake theme on my site http://militaryminatureshq.com On my homepage I used the shortcode [blog_list thumb="large" showposts="10" offset="1" post_content="excerpt" category_in="118,119" pagination="true"] and when the featured image is clicked it takes you to the post. However when I use the same code on the MMTV page, when the featured image is clicked it shows a lightbox. How can I change this?

    Posted 3 years ago #
  2. Elliott
    Support

    Hello branditsocially,

    I tried viewing your link but it's giving me a 404.

    Posted 3 years ago #
  3. branditsocially
    Member

  4. Elliott
    Support

    Is "News Feed" your blog page? You appear to be using a plugin there.

    Posted 3 years ago #
  5. branditsocially
    Member

    The news feed is a subdomain with a third party app. That is not what I want to change. The page I would like to change is MMHQ TV. As I said, when I put the same shortcode that I use on the home page onto the MMHQ TV page then the images are lightbox and do not link to the post page as they do on the home page.

    Posted 3 years ago #
  6. Elliott
    Support

    Open up /wp-content/themes/[your_theme]/lib/functions/image.php and change lines 66 - 67 from this,

    'link_to' => $link_to,
    'prettyphoto' => $prettyphoto,

    To this,

    'link_to' => get_permalink(),
    'prettyphoto' => false,
    Posted 3 years ago #
  7. branditsocially
    Member

    I tried that code and now the images are not appearing. I changed the code back and they do not reappear.

    Posted 3 years ago #
  8. branditsocially
    Member

    The feature images are not showing on the post page either. On both the home page and the post page is just shows them as loading.

    Posted 3 years ago #
  9. branditsocially
    Member

    I restored the files from backup and the images are appearing now but as I mentioned when I changed the two lines of code the featured images would not appear. I'm not sure if this matters but I am using Cloudflare

    Posted 3 years ago #
  10. Elliott
    Support

    That should be working. Add the change back in and let us know when your done so we can check it.

    Posted 3 years ago #
  11. branditsocially
    Member

    OK, I changed the two lines of code as you described. It doesn't appear that anything changed on the MMHQ TV page. They are still showing lightbox

    Posted 3 years ago #
  12. Elliott
    Support

    Hmm, not sure what to tell you here. It works fine on my XAMPP setup.

    Posted 3 years ago #
  13. branditsocially
    Member

    So what are my options?

    Posted 3 years ago #
  14. Elliott
    Support

    Try uploading a fresh copy of the theme and try the edit again.

    Posted 3 years ago #
  15. branditsocially
    Member

    I have the featured images now appearing correctly on the MMTV page. How do I remove the social share icons on the MMTV page but still have them on the individual post page? This is the shortcode I am using. [blog_list thumb="large" showposts="6" post_content="excerpt" category_in="3" pagination="true"] When I preview the page the social sharing icons do not appear, but when I view the page they do.

    Posted 3 years ago #
  16. Elliott
    Support

    Add this to your custom CSS,

    .post_list .sharedaddy {
        display: none;
    }
    Posted 3 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme