Fancy Image Links

pending (9 posts) (5 voices)

  1. poolvibe
    Member

    I can't figure out why the links are broken? The page just reloads instead of the linked page coming up.

    Page in question... http://harmonyoutreach.org/test123/

    [fancy_images width="145" height="200"]
    [image caption="Allen" link_to="http://harmonyoutreach.org/sponsor-allen/"]http://harmonyoutreach.org/wp-content/uploads/allen_china.jpg[/image]
    [/fancy_images]

    Posted 3 years ago #
  2. I am having the same issue here: http://www.zhounder.com and here: http://sanchezariasphotography.com

    Code from zhounder.com homepage:

    Choose a Gallery

    [fancy_images width="220" height="220"]
    [image caption="Man Made" link_to="http://zhounder.com/galleries/man-made/"]http://zhounder.com/wp-content/uploads/2013/05/SnowyBostonBW1.jpg[/image]
    [image caption="Nature" link_to="http://zhounder.com/galleries/nature/"]http://zhounder.com/wp-content/uploads/2013/05/dsc_0353_tonemapped-edit.jpg[/image]
    [image caption="Nudes" link_to="http://zhounder.com/galleries/nudes/"]http://zhounder.com/wp-content/uploads/2013/05/MarleyJacobs-Web-011.jpg[/image]
    [image caption="People" link_to="http://zhounder.com/galleries/people/"]http://zhounder.com/wp-content/uploads/2013/05/Jasmin-012.jpg[/image]
    [/fancy_images]

    The other site has similar code.

    Attachments

    1. FancyImageLinks_Broken.jpg (88.5 KB, 1 downloads) 3 years old
    Posted 3 years ago #
  3. Elliott
    Support

    Hello everyone,

    It's a bug with the latest version of Wordpress 4.0.1. I let our devs know and we should see a fix soon.

    Posted 3 years ago #
  4. poolvibe
    Member

    Would be nice to know whether this fix will take hours, days, or weeks. I have several not so happy clients right now...

    Posted 3 years ago #
  5. UPDATE:

    I checked a number of sites to see if I could find any commonality to this issue. The image above is from 1 site and there are 3 other sites on the same server. Of the 4 sites, 2 have this purple and 2 don't. Some have updated plugins, some don't. The data I have is in the table (image) attached.

    *Red indicates plugin needing updates (all are no more than 1 version behind.
    *All Themes on the most current version

    Attachments

    1. Screen-Shot-2014-11-24-at-3.57.52-PM.jpg (90.8 KB, 2 downloads) 3 years old
    Posted 3 years ago #
  6. Rather than add this to every page that has this issue, I thought I would just post it here as poolvibe is already on many of those threads.

    The issue with the update to WP 4.0.1 is that MSMW is trying to circumvent inconsistencies in parsing the code. The issue is that when you do that outside the parameters of the WP shortcode API you only gain short term security. The intentions were good but the long term results are not.

    Here is the way to fix the issue listed in this article: https://wordpress.org/support/topic/issues-with-wordpress-401-and-shortcodes
    The problem is depending on how much needs to be re-parsed and re-coded it may take a while to fix the problem. Fixing on plugin is relatively easy and quick but when you build this much functionality into a framework things will break that aren't even related.

    One short fix can be seen here: https://wordpress.org/support/topic/upgrade-to-401-broke-plugin
    The issue is that how many lines of " are in the code for MSMW themes and how are they generated.

    The option of downgrading to version 4.0 is an option but it is highly recommended that you NOT do that as this was a major security update.

    To Elliott: Are we looking at days, weeks or months here? If all your clients go out of business you will too. Please answer this question before we all go under.

    Thank you.

    Posted 2 years ago #
  7. Hello Elliot,
    We are having the same problems, updated WP to 4.0.1 a couple of days ago.
    Now the fancy images here http://www.kevalastairs.com/projects/
    and in another parts of our web do not link to the actual projects. Or the alt text is not displaying. Also the caption is not showing properly.

    example
    [fancy_images]
    [image title="South Kensington Mews" alt="South Kensington Mews" caption="South Kensington Mews" link_to="/projects/south-kensington-mews/"]http://www.kevalastairs.com/wp-content/uploads/2014/08/South-Kensington-Mews-12.jpg[/image]
    [/fancy_images]

    Micael Albany has a point, the fix should be a matter of hours rather than days or weeks. Our website is image based and our clients are unable to view our portfolio of work.
    Hope you can fix it soon

    Posted 2 years ago #
  8. Hello
    I have logged an issue over a month ago and had no reply as yet. Our website is still not working properly. Are you going to resolve the issue soon?
    Thank you

    Posted 2 years ago #
  9. Webtreats
    Support

    Thanks for your patience.

    Make sure your theme is up to date:
    http://mysitemyway.com/theme-updates-for-04-18-14/

    And then replace the following files on your server with the ones in the zip file below:

    lib/classes/raw-shortcode.php
    lib/shortcodes/18-images.php

    Let us know if this resolves the fancy image shortcode issue.

    Attachments

    1. fancy_images_fix.zip (3.9 KB, 1 downloads) 2 years old
    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme