Facebook Comments

pending (8 posts) (4 voices)

  1. matthewlock
    Member

    Recently Facebook have allowed their commenting system to be placed on other website pages and their is a plugin on wordpress.org to put this on WP blogs. I've tried on my install of Awake and nothing shows up. It's quite likely my own awake/wp settings are not allowing this to work but I wondered if anyone else had managed to get this working with awake yet?

    Details here:
    http://developers.facebook.com/blog/post/472/
    http://developers.facebook.com/docs/reference/plugins/comments/
    http://forum.developers.facebook.net/viewtopic.php?id=56459

    and the plugin is here:
    http://wordpress.org/extend/plugins/facebook-comments-for-wordpress/

    Anyone with input on this greatly appreciated. I've not had time to go into in-depth yet. My next attempt was to deactivate the plugin and just paste the FB code in the header and footer and go from there.

    MAtt

    Posted 3 years ago #
  2. Elliott
    Support

    Hello matthewlock,

    I tried setting this up but for some reason facebook was not letting me get past the "Create a facebook app" step. From what I have been reading it seems a lot of people are having issues with it so far.

    If possible then send us a link to your site so we can take a closer look.

    Posted 3 years ago #
  3. matthewlock
    Member

    well an example would be http://www.welshbockers.co.uk/news/welshbockers-featured-on-projump-exo-boxes/

    However as this is a live site I undo anything I try that doesnt work so at present the facebook plugin is deactivated and WP comments are disabled.

    I'm not so much looking for the support team to help here, but just thought this is a new idea from facebook that is likely to catch on quite quickly and Awake users might be able to share their experiences with what works and what doesnt until we have good solution.

    For what its worth, with comments enabled and the plugin installed I get a Comments Disabled notice at the bottom of the post. I've seen other WP users post about this on the facebook forums but with so many different installs its very hard to pinpoint.

    Posted 3 years ago #
  4. Elliott
    Support

    I'm still having trouble getting it setup, it's probably just something with my account. I found a small tutorial on how to set it up manually though, http://developers.facebook.com/blog/post/198, so if you'd like we can try this.

    Open up /wp-content/themes/awake/header.php and on line 2 you should see this,

    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>

    Change it like this,

    <html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>

    Next open up /wp-content/themes/awake/single.php and on lines 99 - 101 you should see this,

    <div id="comments">
    	<?php comments_template('', true); ?>
    </div>

    Change it like this,

    <script src="http://static.ak.connect.facebook.com/js/api_lib/v0.4/FeatureLoader.js.php"
    type="text/javascript"></script>
    
    <fb:comments></fb:comments>
    
    <script type="text/javascript">
    FB.init("YOUR_API_KEY_HERE", "<path from web root>/xd_receiver.htm");
    </script>

    And be sure to change "YOUR_API_KEY_HERE" with the API key that you received from setting up the Connect Application.

    Go ahead and try that out matthewlock.

    Posted 3 years ago #
  5. matthewlock
    Member

    Thanks for trying Elliot, I've made the changes, inserted my API key and uploaded the xd_receiver file to the web root but there is no sign of anything facebook on my pages or posts :/

    It hasn't broken anything so I'll leave the changes in place until someone else finds a way to get this to work.

    Posted 3 years ago #
  6. @matthewlock
    Have you looked at the source code yet, to check whether anything is parsed at all or only in a wrong format. I have had issues with Awake and Facebook code before and figured that it was caused by the quote signs which Awake via WP's add_filter turned into fancy quotes, messing up the FB HTML source code.

    HTH,

    Helmar

    Posted 2 years ago #
  7. @matthewlock
    You can try what Helmar said by adding these lines of code in \wp-content\themes\awake\functions.php, just before the closing php tag ( ?> )

    remove_filter('the_content', 'wptexturize');
    remove_filter('comment_text', 'wptexturize');
    Posted 2 years ago #
  8. matthewlock
    Member

    thanks I will try this and report back.

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme