Cufon Fonts not taking

resolved (20 posts) (5 voices)

  1. mdstine
    Member

    I seem to be having some trouble with the cufon fonts. For some reason no matter what I do I cannot change the font in any skin. It seems to be locked in on the "Collaborate" font. All of the cufon fonts are sitting on the server exactly where they should be and I think permissions etc. should be fine. But no matter what I change the font to it still remains the same. Any thoughts?

    http://romanticcentury.org/wp

    Thanks

    Posted 6 years ago #
  2. Elliott
    Support

    Hello mdstine,

    If possible then PM us a Wordpress login so we can take a closer look.

    Posted 6 years ago #
  3. mdstine
    Member

    I just sent you a message using the general contact form. Not sure if that was the best method but couldn't find another way to PM you.

    Posted 6 years ago #
  4. mikesweatman
    Member

    I too am having problems changing the fonts with 2.0. I have followed the tutorial for 1.6 but obviously it doesn't work. Can you please let me know how I can globally change the font?

    Posted 6 years ago #
  5. Elliott
    Support

    Hello mikesweatman,

    You can change them with our skin editor, http://mysitemyway.com/docs/index.php?title=Customization&action=edit&redlink=1.

    mdstine's issue was that he was just changing the wrong section. If your cufon font is not changing then take a screenshot and highlight the area and we'll point you to the correct section in the skin generator.

    Posted 6 years ago #
  6. Hello, me too I have the problem to change cufon font on my site (inFocus wordpress).

    I have already read all new inFocus documentation and forum workouts - nothing helped.

    I generated a new Cufon-font through Cufon-font-generator, uploaded it to /inFocus/lib/scripts/fonts (checked the permissions - ok).
    Then, I tried to change the font by two ways - neither worked.
    /just to note/** I did all the theme customization by changing the /style/....css file - everything worked but for cufon.//

    1 - I replaced in /style/.....css all 'font-family:colaboratelight;' with 'font-family:specialk;' (the same as the font generated by cufon - specialk.js) - instead of applying new font - it changed to simple serif (not even cufon).

    2 - I changed all cufon fonts for the new one through the Skin generator in my dashboard (by going to 'Manage themes' > 'Edit') - the result was the same - simple serif! AND, moreover - it screwed up the whole style! my custom header, footer, meta and content fonts changed to default (though, I didn't touch these in the Skin generator).
    -->In order to have all my settings and customization back, I had to completely upload the backup of my /style/....css file and image folder and rename it! Neither reuploading it with the same name, nor customizing the broken header/footer images and font styles in the Skin Generator - worked. All folders and files permissions were also okay (I always check it in the first place).

    It seems like the theme understands and applies only the default Cufon font used in this or that style. I tried to switch to another theme with another cufon-font used - it was the same((

    I hope I described my problem clearly enough :)
    Please, help! and I don't want to do this through the Skin generator - it screws up all my long customization work and I have no patience left to re-customize it there anew... Thanks!

    Posted 6 years ago #
  7. Elliott
    Support

    Hello Greya,

    If your adding your own cufon fonts see here, http://mysitemyway.com/support/topic/additional-cufon-fonts-not-woking.

    Posted 6 years ago #
  8. Thanks a lot, Elliott! Don't know how I missed that post. Sorry for all my long explanation..

    Just another small question - what should I write in the Custom CSS to make different color on hover of the Main Menu and Submenu links. I've tried different variants (like '.jqueryslidemenu a:hover, .jqueryslidemenu ul ul a:hover {color:#ccc !important;}') but what it makes is - it applies my custom color on hover, but when I take away the mouse from the link - the link stays in color, instead of changing back to the initial '.jqueryslidemenu a' color. And the submenu link doesn't change at all on hover.
    As you can see, I managed to change other colors in the menu/submenu, except for the hover.
    Thanks again for your support!

    Posted 6 years ago #
  9. Elliott
    Support

    If possible send us a link to your site or let us know which theme you are using.

    Posted 6 years ago #
  10. It's http://greyarium.com/ - InFocus on wordpress. Thanks!

    Posted 6 years ago #
  11. Elliott
    Support

    I think we just added cufon hovers to the latest version. Try updating to 2.4. If that does not work then we'll try a custom javascript fix.

    Posted 6 years ago #
  12. Oh, I didn't know about the update. Where can I download it? (it's latest version 2.3 on themeforest)
    Thanks!

    Posted 6 years ago #
  13. Elliott
    Support

    I think it should be available on themeforest now. Try downloading once more and if it's not 2.4 you can try contacting themeforest support.

    Posted 6 years ago #
  14. Hello, Elliott.

    I've re-downloaded inFocus on Themeforest several times throughout the day and it's still v2.3.
    I've also contacted Themeforest support (Envato marketplace > ticket) and they told me to contact inFocus support team for the v2.4 update))) So, here I am again :)

    I understand, hover possibility is not a major trouble, but I'd like to finally apply all updates and finalize the customization before uploading posts, in order not to have to recustomize shortcodes and new posts after another update..

    Is v2.4 really available? - I didn't see this version in the Changelog on Themeforest neither.
    Thanks, Greya

    Posted 6 years ago #
  15. Elliott
    Support

    Sorry Greya, it was our newer themes that were updated to 1.4 with the cufon hovers. inFocus and Awake are still being worked on.

    Go ahead and try adding this code in Dashboard -> your theme -> General Settings -> Custom Javascript,

    jQuery('.jqueryslidemenu a').hover(function(){ jQuery(this).css('color', 'black'); Cufon.replace('.jqueryslidemenu a', { fontFamily: 'Arvo' }); }, function(){ jQuery(this).css('color', 'white'); Cufon.replace('.jqueryslidemenu a', { fontFamily: 'Arvo' }); });

    And then switch the colors and the font name with your own.

    Posted 6 years ago #
  16. Hello, Elliott.

    I've tried the Custom Javascript - that's how it worked:
    > it enabled the color for the main menu hover, but with a 2-3sec delay for every hover,
    > as for the dropdown menu - it enabled the color for hover, but not for the current item hovered, but for the previous I hovered on (i.e. when I hover on "2" in a list the "1" changes its color).

    I found another solution! Just simply enabled hover for Cufon:

    I changed line 1824 in '/lib/functions/theme.php'

    $out .= "\r\tCufon.replace('.jqueryslidemenu>ul>li>a', { fontFamily: '{$font}' });";

    like this

    $out .= "\r\tCufon.replace('.jqueryslidemenu>ul>li>a', { fontFamily: '{$font}', hover: true });";

    Now, it works perfectly on main-menu (http://greyarium.com/blog/).
    But, I couldn't enable hover for dropdown-menu items. I've tried to add the same hover: true to the section # Dynamically load cufon on drop downs in 'theme.php', but it acted strangely. I'm sure I was doing it wrong here, for I'm not familiar at all with javascript..

    Could you, please, help me with the dropdown menu section?
    Just tell where should I correctly insert hover: true for dropdowns :)

    Thanks again!

    Posted 6 years ago #
  17. Elliott
    Support

    You have the right idea Greya, go ahead and put the hovers back on for the dropdown menu as well.

    It seems that with inFocus there is a CSS transition when you hover over the sub menu links that is messing it up.

    Try opening up /wp-content/themes/infocus/style.css and on line 580 you should see this,

    .jqueryslidemenu ul ul a {opacity: 1;
    -webkit-transition: all .5s ease;
    -moz-transition: all .5s ease;
    -o-transition: all .5s ease;
    transition: all .5s ease;}

    Try commenting out or deleting that.

    Posted 6 years ago #
  18. Finally - It worked! All color menu/submenu hovers work! it was really the CSS transition messing up hovers on cufon.

    This also worked for the color on hover for Blog Post titles with Cufon (which I was asking here (http://mysitemyway.com/support/topic/change-post_title-font-size-for-popularrelated-posts-module?replies=1#post-31015). I've posted a link to this thread there - in case, someone's in search for same solution.

    Hope this will be included as a bugfix into the next inFocus update :)
    Thanks again! Your support is awesome - professional and fast - really nice to deal with you guys!

    Posted 6 years ago #
  19. sublingua
    Member

    I need to change the hover color in my main and sub menus. How can I do this without changing other hover colors? I have tried many of the solutions I have seen here and nothing has worked. If you go to Moms4pop.org you can see the need for this.

    thanks so much,
    Rebecca

    Posted 4 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme