CPU Load / Very slow pages loading

resolved (24 posts) (4 voices)

  1. Hello,

    I'm running Wordpress 3.3.1 with Awake 1.3 and some popular plugins, like QTranslate, NextGen Gallery, Contact Form 7, WP SuperCache, etc.

    I'm running it on a dedicated server with Plesk 9, PHP Version 5.2.4-2ubuntu5.14 / 64Bit OS with 512 MByte memory (using 71.3 MByte, 14%). Everything works fine, and pages load between 0.5-1.5s depending of the contentm, and the CPU Load of the server is between 0%-2%

    I've made a copy of this installation and database for upgrade the template. I've updatde Porfolios, Widgets and others, and everything works fine, but the CPU Load increases to 99%-100%. I've create the cache folder in the theme folder, give it 777 permissions, etc and nothing change the CPU Load. I've tried to disable WP-SuperCache, and the same. And, watch this, the page load time increases up to 121.719s! When I switch to a WP Built-in theme, everyting works fine, and the CPU Load is between 0%-2% again.

    Spent a lot of time on this, and don't find where the problem is. Even I've purchased Persuasion 2.0, and the problems are the same (it's the same framework).

    Thanks for your help, if you need more information, please, ask me and will send it.

    Posted 2 years ago #
  2. Elliott
    Support

    Hello FeedbackMP,

    Deactivate your plugins and send us a link to your page.

    Posted 2 years ago #
  3. Hello Elliott,
    You can see the site here (Awake 2.9): http://www.feedbackmp.com/web-new/ The texts look weird because QTranslate is deactivated (all the plugins, in fact)

    You can see the current site here (Awake 1.3): http://www.feedbackmp.com/

    In this situation:
    -CPU Load is 20%
    -The site /web-new/ loads so slow

    It could be some problem with the .htaccess files?

    Than you!

    Posted 2 years ago #
  4. Elliott
    Support

    I'm getting about 20 seconds before the page loads and it's constant for each page no matter how many images your using, etc etc. I would say it's something to do with the server. Have you contacted your hosting provider?

    Posted 2 years ago #
  5. Hi Elliott,
    With all the plugins activated (except WP Super Cache), it seems that pages load faster, CPU Load increases up to 60%-80%
    http://www.feedbackmp.com/web-new/

    I've talked with my dedicated administrator, and he can't tell me what's wrong or whats the script that is causing problems... any suggestion? What's the best server configuration for your framework (which are you using in your demos)?

    Posted 2 years ago #
  6. Webtreats
    Support

    Hi FeedbackMP,

    Try putting the following code into your .htaccess file and see if you new site loads faster:

    http://www.samaxes.com/2009/01/more-on-compressing-and-caching-your-site-with-htaccess/

    Posted 2 years ago #
  7. Hi Webtrats,
    Yesterday I've been working on .htaccess files and it seems that the problem is there, because meanwhile the new site is not published, there are two .htacces files, one in the /httpdocs/ root and the other on the /new-site/. I'm still working on it, I'll try to put the this code into the root and tell you how it works.

    Thank you

    Posted 2 years ago #
  8. Hi again,
    There's no way, I'm spending a lot of time on this and can't found where is the problem. If you want, I can send my .htaccess in a PM, because it works with Awake 1.3 and don't with 2.9

    Posted 2 years ago #
  9. Hello again Elliot & Webtreats,
    Do you have any idea, before trying to install everything from 0? I've been trying everything, even to reinstall the pluguins and there's always the same result: the CPU loads increases a lot, and when don't, the pages load very slow.

    What do you recommend?

    Posted 2 years ago #
  10. Elliott
    Support

    Try creating a backup of your .htaccess file and then delete it to see if it's what's causing the issue.

    Posted 2 years ago #
  11. Hello Elliott, thank you, it works, without an .htaccess files, the cpu load is 0%., but when another one is recreated (I'm using fancy permalinks), the cpu load increases again. The permalinks structure is: /%category%/%postname%/ and the htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /fmpwp-site/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /fmpwp-site/index.php [L]
    </IfModule>

    # END WordPress

    (As you can see, I've created a copy of the current installation in a new folder)

    Posted 2 years ago #
  12. Elliott
    Support

    And this happens when using the default theme as well?

    Posted 2 years ago #
  13. No, only with Awake 2.9, with the default theme there's no problem with the CPU

    Posted 2 years ago #
  14. Elliott
    Support

    And you've contacted your hosting provider? What did they say?

    Posted 2 years ago #
  15. We have checked the top processes via top ssh command. When Awake is activated, there are some processes using a lot of CPU but we can't identify which scripts causes it. What server configuration do you recommend (its a dedicated one)?

    Posted 2 years ago #
  16. Elliott
    Support

    So your hosting it on your own server? A dedicated server is not required for our framework but it does help.

    Posted 2 years ago #
  17. Yes, it's hosted on our own dedicated server, so what we can do?

    Posted 2 years ago #
  18. Elliott
    Support

    Check with your hosting provider and let us know what they say. It's most likely something with your .htaccess file and the server.

    Posted 2 years ago #
  19. They told me that the problem is on the template. I suspect that is on the updating script (I've done all the steps specified on your website). Take a look here http://test.feedbackmp.com/, it's a new WP installation, importing your XML content file (and the content of my current site),with the same plugins activated, the same htaccess... and it works fine and the cpu load is about 0-5%

    Posted 2 years ago #
  20. Elliott
    Support

    I don't know. I would work with your hosting provider to try and figure out what the difference is between,

    http://www.feedbackmp.com/

    And,

    http://test.feedbackmp.com/

    Though I just checked it again and it doesn't seem to be hanging anymore.

    Posted 2 years ago #
  21. I have the same problem with Infocus. Phoned the hosting provider and they said there are lots of sleeping SQL queries that are not being closed.

    I have the problem ONLY with the latest version of Infocus, but not with any other theme (ie TwentyEleven or an old Awake).

    What gives?

    PS: The site is http://www.constellationhouse.co.za

    Posted 2 years ago #
  22. Elliott
    Support

    When I try to view your link I get a, "Service Temporarily Unavailable", message.

    Posted 2 years ago #
  23. Yes, probably because there is no response to the database queries, which are all sleeping. I will set it back to the old Infocus, and then you will see that the page loads fine (except for the menu, where I am told that the 1.6 infocus doesn't support WP menus).

    If I have the WP Maintenance plugin ACTIVE, I can see the site just fine. The moment I deactivate (not disable) the maintenance mode, it goes back to lots of sleeping queries.

    Posted 2 years ago #
  24. Webtreats
    Support

    Hi helmar,

    Both WordPress and our theme do not create persistent connections to the database when it is not running. It uses mysql_connect, with NON-persistent connections.

    If you are getting persistent connections, then this is a problem with your PHP or webserver configuration in some way.

    I'd recommend trying a caching plugin:

    http://wordpress.org/extend/plugins/search.php?q=cache

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme