Contact forms to multiple addresses

resolved (25 posts) (5 voices)

  1. david
    Member

    Is it possible to send the form data to more than one email address?
    I have tried entering multiple with separation by comma and semicolon but it only uses the first email address.
    I have also tried two different "email=" in succession but in that case it uses the last email address.

    Thanks

    I don't want to resort to another forms plugin as the interface with these themes is so slick!

    Posted 5 years ago #
  2. david
    Member

    OK, that works.

    changing line 41 in /wp-content/themes/[your_theme]/lib/shortcodes/16-contact.php from this,

    $form_inputs['mysite_email'] = ( is_email( trim( $email ) ) ) ? trim( $email ) : get_option('admin_email');

    To this,

    $form_inputs['mysite_email'] = trim($email);

    Cheers

    Posted 5 years ago #
  3. sjdeardorff
    Member

    Hello. I have tried this repeatedly and it simply will not work. Every time I change that line 41, the contact form breaks and mail is never received. In fact, I have had to replace that 16-contact.php file with the original and I still cannot get the form to work again. I must be able to have this send to two email addresses (one is admin). I really don't want to have to hardcode the email addresses as I'll have to change that at least once a year plus it will get saved over if there are any theme updates. Help? Thanks

    http://www.ascewinw.org/

    Posted 4 years ago #
  4. Elliott
    Support

    I sent you a test email. Check your inbox and spam folders.

    Posted 4 years ago #
  5. sjdeardorff
    Member

    I haven't received any emails. Since I could not get multiple emails to work, I tried just using the main ascewinw@gmail.com address, then forwarding a copy to the other email address in the GMail settings. Not receiving the emails to either.

    Posted 4 years ago #
  6. Elliott
    Support

    Create a backup and completely delete the theme before downloading / uploading a fresh copy.

    Try using different emails and also try installing this plugin, http://wordpress.org/extend/plugins/wp-mail-smtp/.

    Posted 4 years ago #
  7. sjdeardorff
    Member

    I bought 4 themes a year ago, and this is the second time that one of them does not show up under My Downloads. I have a copy of Modular 2.1 saved on my computer, but it's not listed under downloads. Same thing happened recently with Deja Vu. So I really have to delete my theme and re-upload another copy?

    Posted 4 years ago #
  8. Elliott
    Support

    I'm not sure I understand. Your having issues with the themes not showing up now? You downloaded a theme from us but after you installed it it's not displaying in Dashboard -> Appearance -> Themes?

    It was most likely not installed correctly then. Go ahead and download / install a fresh copy via FTP, http://mysitemyway.com/docs/index.php/Installation#Manually_installing_via_FTP.

    Posted 4 years ago #
  9. sjdeardorff
    Member

    I'm stating that the Modular theme that I purchased last March does not show up under My Downloads, so I have to access to it. I had purchased Awake, Deja Vu, Echelon and Modular. I don't know why Modular is not available to me now.

    Posted 4 years ago #
  10. sjdeardorff
    Member

    *I have no access to it

    Posted 4 years ago #
  11. Elliott
    Support

    Send us an email here, http://mysitemyway.com/contact, and we'll take a look.

    Posted 4 years ago #
  12. sjdeardorff
    Member

    Just wanted to update you that your suggestion worked. After deleting the theme, then re-uploading a fresh copy, my contact form is now working to both email addresses used in the widget. Thanks again!

    Posted 4 years ago #
  13. sjdeardorff
    Member

    Guess I spoke too soon. As soon as I changed one of the email addresses, the form stopped working (no emails received). I tried the change to line 41 of the 16-contact.php file, but still no go.

    Posted 4 years ago #
  14. Elliott
    Support

    Are you sure it's not just a specific email that is not working? Try changing it back to the other two emails that were working to see if they still work.

    Posted 4 years ago #
  15. sjdeardorff
    Member

    Yes, I tried that and it still didn't work. Sorry to be a pain here.

    Posted 4 years ago #
  16. Elliott
    Support

    Go ahead and completely delete the theme before downloading / uploading a fresh copy.

    Posted 4 years ago #
  17. sjdeardorff
    Member

    Again? I did that this morning already.

    Posted 4 years ago #
  18. Elliott
    Support

    And you said it was working until you changed the email address.

    It's working fine on my end and for other customers so I don't really know what else to tell you. Perhaps it's some kind of customization that has been done or a plugin.

    Posted 4 years ago #
  19. sjdeardorff
    Member

    This is so bizarre. I can only get this form to work if I disable BackUpWordPress, Email Address Encoder and All in one SEO Pack plug-ins. It also does not work if I enter any Google email address for email. So confused. The only other plug-ins I'm using are Google Calendar Events and Google Calendar Widget, both of which I need.

    Posted 4 years ago #
  20. Elliott
    Support

    It's probably the email address encoder. We already include a captcha with our form so it's not needed.

    Posted 4 years ago #
  21. sjdeardorff
    Member

    Email encoder scrambles send to email addresses so that spambots cannot read them. Captcha doesn't do that, does it? I still couldn't get it to work with SEO and Back up activated, nor would any gmail address entered into the email field work.

    I have all of these plugin used in two other sites using your themes, and no problems with the contact form on them.

    Posted 4 years ago #
  22. Elliott
    Support

    Send us a private message by clicking on the "PM this user" link beneath our usernames and include a Wordpress login + link back to this topic.

    Posted 4 years ago #
  23. The "Line 41" fix worked for me!

    Posted 4 years ago #
  24. omg
    Member

    I can confirm "Line 41" worked for me as well.

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme