Construct Theme "This page is trying to load scripts from unauthenticated source

pending (14 posts) (2 voices)

  1. rickchapman
    Member

    Hi. Construct is generating "This page is trying to load scripts from unauthenticated sources" errors in Chrome, IE, and Opera.

    I have disabled all plug ins. After doing this, the error does not go way.

    I have switched to the default WordPress themes with all plug ins disabled. The error goes away. I switch back to Construct. The error returns.

    This error message seems to have appeared very recently. I have just updated to WP 4.3 and am wondering if that may be the problem?

    Can someone please advise? This issue basically cripples the site. The site does implement SSL on some pages and has successfully processed transactions. However, this error of course makes ecommerce scary to many people.

    Please advise.

    rick

    Posted 2 years ago #
  2. rickchapman
    Member

    I've done further work on this problem and it does appear this theme is broken. This is what the analysis of the mixed content is:

    http://www.saasuniversity.com
    - http://saasuniversity.com
    - src='http://
    - src="http://
    - src=http://

    Option: useronline
    Option: mysite_construct_options
    Option: rcp_settings
    Option: _transient_wpseo_sitemap_cache_1_
    Option: _transient_feed_d117b5738fbd35bd8c0391cda1f2b5d9

    In the SSL settings, "Auto replace mixed content" and all the standard WP themes behave properly with no blocked content warnings and the "lock" on the website pages displaying.

    However, Construct does not seem to be responding to "Auto replace" and showing blocked content messages on all of the sites pages.

    IOW, Construct cripples an ecommerce enabled site.

    Posted 2 years ago #
  3. Elliott
    Support

    Hello rickchapman,

    I checked your link but you don't appear to be using Construct there.

    Posted 2 years ago #
  4. rickchapman
    Member

    Hi, Eliot. I've been testing the site with different themes to see if the problem occurs with other themes. So far, it does not.

    I have switched back to Construct. Please try it now.

    rick

    Posted 2 years ago #
  5. rickchapman
    Member

    Can you please respond? Because I have a dead ecommerce site and it appears to be your theme that's causing this problem. I tested against a dozen themes, including the ones from Easy Digital Downloads, the ecommerce engine I use and they do not cause any blocked content errors. I paid for this theme and to have it bring my site to its knees is upsetting. If you can't fix it, can I obtain a refund? Because right now, this is my dead site, not my way.

    rick

    Posted 2 years ago #
  6. rickchapman
    Member

    Well, my site is still crippled by Construct and it seems that for $35 dollars I bought a huge headache. I'm now in the process of looking at alternate themes (all of which work fine, BTW and generate no blocking errors from browsers). I'm going to start blogging and writing about this fiasco if I don't get some help here. I think you should stop selling Construct, or at least warn people it's unsuitable for use on https sites so no one has to experience a crippled site like I am.

    rick

    Posted 2 years ago #
  7. Elliott
    Support

    Can you deactivate all plugins? Everything is minified so it's hard to troubleshoot.

    Posted 2 years ago #
  8. rickchapman
    Member

    I can do that and just did. ALL plugins are now off. As a quick experiment, I activated Simple SSL and the content blocked message appears on Opera and other browsers while Construct is active. I switched to 20 15 and the content blocked message disappears. I have turned off Simple SSL and switched back to Construct. Content blocked reappears.

    rick

    Posted 2 years ago #
  9. rickchapman
    Member

    I can provide admin access if you need it.

    rick

    Posted 2 years ago #
  10. rickchapman
    Member

    Hello? Anyone around? Anyone here?

    rick

    Posted 2 years ago #
  11. rickchapman
    Member

    You know, sending me one message a day is not going to cut it. I'm not able to wait weeks while this is resolved.

    rick

    Posted 2 years ago #
  12. rickchapman
    Member

    OK, forget it. This is ridiculous. Clearly your company is on life support and heading for extinction. I dropping my use of Construct and will be warning people to stay away from the product and your company. A theme that cripples ecommerce sites is not fit for sale.

    rick

    Posted 2 years ago #
  13. Elliott
    Support

    Ok I can see the errors now that you have deactivated all plugins. More importantly though I noticed your using an outdated version of Construct, 1.6. The latest version is 1.8 so update first and then we'll continue.

    Posted 2 years ago #
  14. rickchapman
    Member

    I have upgraded to 1.8. Lost all my tweaks and configurations. The system still shows a blocked content message. Other themes do not.

    I'm out of here. I've been reading the other messages about what's happening her and you're clearly going out of business. I will be warning people to stay away.

    rick

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme