Comment Button Missing

resolved (12 posts) (8 voices)

  1. gcrocker
    Member

    Our blog section's Comments forms are missing their "Submit" buttons:

    http://placitaslibrary.com/uncategorized/labyrinth-dedication-march-21st/

    Previewing other themes, it shows up. Disabling all plugins with Modular still in use didn't fix the problem.

    Any ideas?

    Posted 2 years ago #
  2. Hi,

    I'm having the same problem with the InFocus theme. The symptoms are the same; no submit button after the leave a comment section. This is the case for Posts and my Portfolio items.

    I've tried deactivating all plugins and installing fresh versions of infocus 3.7 and 3.6, all with no success. I've also swapped themes as gcrocker has done (to twenty-15) which immediately solves the problem. I am using inFocus with the infocus-jigoshop child theme.

    I've checked in the comment settings, and all appropriate settings to allow comments are enabled. In settings -> posts, I can see that "allow comments" is also ticked for all posts when I select "Quick Edit".

    I notice on looking through the page source code that there is nothing in the appropriate section of html code that would allow for a post button to be displayed:

    </div><!-- #respond -->
    <div class="clearboth"></div>
    </div><!-- #main_inner -->
    </div><!-- #main -->

    I can see the code for the text boxes and such, but in this section, as I say, there's nothing. Just having looked quickly at the OP's blog pages' source, he appears to have exactly the same issue.

    I think - but unfortunately am not 100% sure - that this may have happened with an update to Wordpress 4.2.

    My blog is at: http://www.chasingrays.co.uk/wpsite/blog if anyone wouldn't mind having a look.

    Any help would be much appreciated.

    Posted 2 years ago #
  3. Can't seem to edit my post above, but the form submission code is:

    <div id="respond" class="comment-respond">
    <h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/wpsite/photography-outings/kedleston-hall/#respond" style="display:none;">Click here to cancel reply.</a></small></h3>
    <form action="http://www.chasingrays.co.uk/wpsite/wp-comments-post.php" method="post" id="commentform" class="comment-form">
    <p class="form-author"><input type="text" class="textfield" name="author" id="author" value="" size="40" tabindex="1" /><label for="author" class="textfield_label">Name <span class="required">*</span> </label></p>
    <p class="form-email"><input type="text" class="textfield" name="email" id="email" value="" size="40" tabindex="2" /><label for="email" class="textfield_label">Email <span class="required">*</span> </label></p>
    <p class="form-url"><input type="text" class="textfield" name="url" id="url" value="" size="40" tabindex="3" /><label for="url" class="textfield_label">Website</label></p>
    <p class="math-captcha-form"><span><input type="text" size="2" length="2" id="mc-input" class="mc-input" name="mc-value" value="" aria-required="true"/> + 14 = 17</span></p>
    <p class="form-textarea"><textarea name="comment" id="comment" cols="60" rows="10" tabindex="4"></textarea></p>
    <p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="80024940a0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="85"/></p>
    </form>
    </div><!-- #respond -->
    <div class="clearboth"></div>
    </div><!-- #main_inner -->
    </div><!-- #main -->

    So it would seem the form submission part of the script is entirely missing - again, this seems to be exactly identical (at least, insofar as it can be) to the OP's page source.

    Posted 2 years ago #
  4. OK, I've managed to recreate this error on my test site, which is running the dejavu theme.

    It is definitely something to do with upgrading to Wordpress 4.2; I upgraded from 4.1.2 (on dejavu) to 4.2, and this immediately broke the submit button on the blog posts on my test site.

    The entire section of code in the

    <p class="form-submit"> .... </p>

    paragraph is entirely missing when I examine the page source.

    Sadly, I have no idea how to fix this myself, but would suggest that people try to stay away from the WP 4.2 upgrade until someone experienced can comment further on this issue.

    Posted 2 years ago #
  5. TEMPORARY SOLUTION TO THIS PROBLEM

    This seems to be a bit more of a problem than I first thought, so I've followed the advice from a comment I've just come across on the Wordpress support site.

    I've copied the file ~/wp-includes/comment-template.php from a WP 4.1.3 archive over the equivalent file in my 4.2 install, both on my test site and, subsequently, to my live website (after backing up the original file, of course). It's worked for both.

    However, if someone more qualified than me could let us know if this is reasonable, that would be great.

    Posted 2 years ago #
  6. EternalPSYOP
    Member

    I don't have access to /wp-/includes/comment-template.php WP 4.1.3 Archive file. I really hoped I could apply your work around slightlydazed. It was suggested that WP 4.2.1 breaks button based on the site host. I go through Blue Host, is there merit to this theory? I'd really like to have a solution to this problem. I've seen it in several forums with this last WP update..

    Posted 2 years ago #
  7. gcrocker
    Member

    The problem seems to be that wp-includes/comment-template.php expects that modular/lib/functions/theme.php's mysite_comment_form_args() return new submit_button and submit_field parameters instead of the old label_submit Modular is returning.

    In modular/lib/functions/theme.php if you find this line:

                    'label_submit' => __( 'Submit', MYSITE_TEXTDOMAIN ),
    

    and change to:

                    'label_submit' => __( 'Submit', MYSITE_TEXTDOMAIN ),
                    'submit_button' => __( '<input name="%1$s" type="submit" id="%2$s" class="%3$s" value="%4$s" />', MYSITE_TEXTDOMAIN ),
                    'submit_field' => __( '<p class="form-submit">%1$s %2$s', MYSITE_TEXTDOMAIN ),
    

    this will be fixed. You can also put your own version of mysite_comment_form_args in your theme (or ideally, child theme) functions.php at the top level and it should work.

    Posted 2 years ago #
  8. tribalromp
    Member

    Same issue here. Thanks for the workaround.

    Posted 2 years ago #
  9. CricketW
    Member

    Thanks for the fix, gcrocker! I was going crazy!

    Posted 2 years ago #
  10. omg
    Member

    FYI anyone looking for the line of code, on the Construct Theme it is on line 2738
    And the above code provided by gcrocker worked perfectly.

    Posted 2 years ago #
  11. Anybody know where to make the same changes in the Method theme?

    Posted 2 years ago #
  12. Elliott
    Support

    It's the same for all themes. Make sure your using the latest version.

    Posted 2 years ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme