broken blog page with static front page

open (24 posts) (2 voices)

  1. I have an issue i want to fix this way. The facts:

    I have to use a static front page, because of styling issues. The BST Theme works good so far, but the blog page breaks down, when i use this setting.

    The way it should look: Screenshot 1
    The way it looks with static front page: Screenshot 2

    I checked all settings. everything is fine.

    So, for test purpose, i created a complete new blog page by using the wp customizer (screenshot 3). When i do that, a blog page appears, with my posts. See Screenshot 4. When i return to the admin menu of my BST, to add the new created blog page as blog page, the blog page breaks down again. See Screenshot 5.

    So the result of my research is, that the BST forces a breakdown of the blog function, when i need to use a static front page.

    Has anyone a solution or an idea?

    Regards
    Colin

    Attachments

    1. result_broken_blog_page.jpg (55.8 KB, 0 downloads) 5 months old
    2. screenshot_5.jpg (92.4 KB, 0 downloads) 5 months old
    3. screenshot_4.jpg (80.3 KB, 1 downloads) 5 months old
    4. screenshot_3.jpg (64.1 KB, 2 downloads) 5 months old
    5. screenshot_2.jpg (36.5 KB, 1 downloads) 5 months old
    6. screenshot_1.jpg (114.8 KB, 0 downloads) 5 months old
    Posted 5 months ago #
  2. OnePressTech
    Member

    You didn't show what your reading settings are configured to. Have you enabled the blog page on the reading settings page?

    Also...if you can provide a link to the failing page people can look at the code to see what the problem is. It's almost impossible to diagnose a bug from a screenshot.

    Posted 5 months ago #
  3. Hello Tim,

    to review the problem, i created a complete new installation on one of my domains. I send you the login details. Please feel free to investigate the problem and make changes as you need.

    1. I installed Wordpress and BST. I set latest post as start page and made the following screenshots. The result: everything works fine.

    Screenshot 1/1-1/4

    2. Now i change the setting to static page in "customizer" in "reading" and in the admin panel, as result, the blog page breaks down.

    Screenshot 2/1-2/4

    3. Now i got into "customizer" and add a new page as blog page. this page is named "blog-nwe". This changing appears automatically in "reading". In the admin panel i don't change the setting, so the admin panel still forwards to "blog" as blog page. The result is a kind of blog page, which design i don't know.

    Screenshot 3/1-3/3

    4. Now i changed the blog page in "construct" admin panel too to "blog-nwe". As result, the blog page breaks down completely again.

    Screenshot 4/1-4/5

    This game i can retry as often as i want, it is always the same result.

    Attachments

    1. 2:2.jpg (70.1 KB, 1 downloads) 5 months old
    2. 2:1.jpg (73.6 KB, 1 downloads) 5 months old
    3. 1:4.jpg (82.3 KB, 1 downloads) 5 months old
    4. 1:3.jpg (105.8 KB, 1 downloads) 5 months old
    5. 1:2.jpg (69.3 KB, 1 downloads) 5 months old
    6. 1:1.jpg (91.9 KB, 2 downloads) 5 months old
    Posted 5 months ago #
  4. Part 2 Screenshots 2/1-2/4

    Attachments

    1. 2:4.jpg (51.9 KB, 0 downloads) 5 months old
    2. 2:3.jpg (102.3 KB, 0 downloads) 5 months old
    3. 2:2.jpg (70.1 KB, 0 downloads) 5 months old
    4. 2:1.jpg (73.6 KB, 0 downloads) 5 months old
    Posted 5 months ago #
  5. Part 3 Screenshot 3/1-3/2

    Attachments

    1. 3:2.jpg (60.7 KB, 0 downloads) 5 months old
    2. 3:1.jpg (84.4 KB, 0 downloads) 5 months old
    Posted 5 months ago #
  6. Part 4 Screenshot 4/1-4/5

    Attachments

    1. 4:5.jpg (51 KB, 0 downloads) 5 months old
    2. 4:4.jpg (70 KB, 0 downloads) 5 months old
    3. 4:3.jpg (71.3 KB, 0 downloads) 5 months old
    4. 4:2.jpg (102.5 KB, 0 downloads) 5 months old
    5. 4:1.jpg (108.6 KB, 0 downloads) 5 months old
    Posted 5 months ago #
  7. OnePressTech
    Member

    Hi Colin,

    The WordPress home page is a bit twisted...see https://wp-mix.com/difference-between-home-front-page-php/ There is a table at the end of this article that shows the different default template hierarchy depending on the home page configuration choice.

    I got your test configuration working by setting:
    Front page: HOME
    Posts page: BLOG

    AND setting CONSTRUCT theme setting Blog Page to HOME (which is odd...I would have naturally chosen Blog for this setting).

    If you want selective blog posts to appear on your home page in addition to your blog page use a plugin like https://en-au.wordpress.org/plugins/list-category-posts/

    Cheers,
    Tim

    PS: I will need to look at this further at a later date. It is not clear to me how MSMW designers related the theme Blog and Homepage settings with the native WordPress Front Page Displays reading settings.

    Posted 5 months ago #
  8. Hello Tim,

    the idea is interesting, but there is one problem: i have to disable the sidebar for this page, if i use the setting you figured out, because, the sidebar appears below all articles.

    Can you give me a timeframe for solving this heavy problem? The recommended plugin doesn't solve the problem in an acceptable way, unfortunately.

    Regards
    Colin

    Attachments

    1. Ohne_Titel.jpg (145.7 KB, 2 downloads) 5 months old
    Posted 5 months ago #
  9. OnePressTech
    Member

    Hi Colin,

    It looks like there is a bug with sidebar display.

    The float:left and float:right are not being applied to the main / sidebar boxesI will make analysis and fix a priority and look to putting out a release next week that fixes this.

    If you keep your test site available I will make sure the new theme update solves the problems in your bluehost environment.

    Cheers,
    Tim

    Posted 5 months ago #
  10. Hello Tim,

    you can use the test installation for your needs. Thank you so far!

    Colin

    Posted 5 months ago #
  11. Hello Tim,

    have you been able to fix the sidebar issue, or are you still working on it?

    Regards
    Colin

    Posted 4 months ago #
  12. OnePressTech
    Member

    Hi Colin,

    Still working on it. Sorry for the delay. It's corporate tax time in Australia so I need a few more days to get that all filed away. Then I'll be back to getting the next BackStop Themes release out.

    Kind regards,
    Tim

    Posted 4 months ago #
  13. Hello Tim,

    thank you for the information. There is no need to excuse, because all the work you do is for the community!

    Thanks so far.
    Colin

    Posted 4 months ago #
  14. OnePressTech
    Member

    Damned tax filings...I would rather be coding :-)

    Posted 4 months ago #
  15. Hello Tim,

    have you been able to fix the sidebar issue, or are you still working on it?

    Regards
    Colin

    Posted 3 months ago #
  16. OnePressTech
    Member

    Hi Colin,

    Apologies for the delay. Still in the queue unfortunately.

    It is taking me some time to work through the MSMW technology deficit to get the BackStop Themes current and to create all the documentation theme users expect (I can't copy it from the MSMW website for Copyright reasons). I have completed two more unreleased updates since the released v1.0.2 themes to fix the skin manager and eliminate a number of errors flagged by ThemeCheck. Once I eliminate the theme technology deficit things will move forward in a more timely fashion.

    Additionally, end of business year in Australia (EOY) is a busy time.Got all my receipts scanned in and indexed and EOY tax accounts up to date but my accountants love to muck around with it. Also had to update my client's plugin suites and test their sites ahead of the upcoming WP4.8 release. Also got in a client consulting contract at the last minute with a two week deliverable (the client is spending EOY money so it had to be completed by June). I updated my client sites yesterday, finishing first consulting deliverable today, done with taxes tomorrow so I expect to be back on BackStop Themes mid week.

    I need to merge recent improvements to create the next release and test for WP4.8 compliance. I will test / repair the blog issue at that time. You should have it by next weekend.

    Thanks for your patience. We'll get there :-)

    Kind regards,
    Tim

    Posted 3 months ago #
  17. Hello Tim,

    i took a look into the new version, it doesn't fix the problem above. Did you forget it?

    Regards
    Colin

    Posted 2 months ago #
  18. OnePressTech
    Member

    Didn't forget Colin. It just has not been fixed yet. Apologies. I'm still time poor as I work through the MSMW technical deficit. There has been a lot of ground to cover to get the theme framework back up to date. I'll try to fast track the next release for next week and make sure this is tested and fixed.

    If you can do me a favour...two actually...could you send me your email address to admin@backstopthemes.com so I can add you to the newsletter. I put out the first issue last week but found that I did not have an email contact for you.

    The second favour is if you could cut & paste the problem info in this post and create an issue in the BackStop Themes issue tracker https://gitlab.com/BackStopThemes/FrameworkV1.0/issues .

    General issues can be added to https://gitlab.com/BackStopThemes/GeneralIssuesForum

    This is where I am managing issue-related discussions since it allows me to track and tag the issue to the release roadmap and we can't rely on this forum any more other than to direct people to the BackStop Themes website and issue tracker.

    Thanks again for your patience Colin.

    Kind regards,
    Tim

    Posted 2 months ago #
  19. Done, good luck, Tim!

    Regards
    Colin

    Posted 2 months ago #
  20. OnePressTech
    Member

    Cheers Colin. I appreciate your assistance.

    Posted 2 months ago #
  21. OnePressTech
    Member

    Bump (to get above the forum spammers)

    Posted 2 months ago #
  22. OnePressTech
    Member

    Bump to get past spam

    Posted 3 weeks ago #
  23. OnePressTech
    Member

    Bump to get past spam

    Posted 2 weeks ago #
  24. OnePressTech
    Member

    Bump to get past spam

    Posted 1 day ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme