BackStopThemes V1.0.1 in progress for 4 Dec launch - PHP7/WP4.6.1 fixes uploaded

open (3 posts) (2 voices)

  1. OnePressTech
    Member

    Hi everyone,

    Quick status report:

    1) For the techies,

    The themes in the https://gitlab.com/BackStopThemes repository have been updated to correct all the PHP7 and WordPress 4.6.1 errors and warnings. Further testing is required to ensure I have covered all the scenarios but the basic out-of-the-box theme now loads cleanly. I have yet to track down if there are any jQuery conflicts that need to be attended to. I also need to review the sub-features (sliders etc) to see if there is a newer version. We will also need to decide how best to gracefully migrate people away from TimThumb so it can be removed. I also need to complete a testing round on an earlier PHP version as I have only tested on PHP7 at present.

    NOTE: Consider the repository as a Beta release until 4 Dec 2016 - use at your own discretion.

    2) For the non-techies.

    I have the Newsletter set up and the new website is complete. I want to do some more testing on the theme and package it up for you as zipfiles so you don't need to deal with the techie repository. You will just need to download the theme to your computer then upload / install it in WordPress as you would have done in the past.

    NOTE: We seem to be on schedule for a 4 Dec release up to WP4.6.1 on PHP 5.4+ including PHP7.
    NOTE: I will do WP4.7 testing the week of 4 Dec and see if we can get a 4.7 compliant release out by 11 Dec...an early Christmas present for you all :-)

    Stay tuned, more to come later in the week...

    Cheers,
    Tim

    Managing Director OnePressTech

    Posted 3 months ago #
  2. Dear Tim,
    thank you so much for all your work.

    Best
    Thomas (non-techy)

    Posted 3 months ago #
  3. OnePressTech
    Member

    You are most welcome @TomBerlin :-)

    I should hit Sunday (Australia time) launch date. I will be asking people to consider that a RC (Release Candidate) version since I will not have sufficient time to do as much testing as I would like and will not have tested against WP4.7. I need another week to get that done.

    I adjusted the theme to eliminate php warnings and errors related to php and WordPress updates that have occurred since MSMW stopped paying attention. I have not yet had time to review the Javascript components to bring them up to the latest jQuery level. I'll tackle that next week.

    Posted 3 months ago #

Reply

You must log in to post.

Construct WordPress Theme
Construct wordpress theme
Myriad WordPress Theme
Myriad wordpress theme
Method WordPress Theme
Method wordpress theme
Fusion WordPress Theme
Fusion wordpress theme
Elegance WordPress Theme
Elegance wordpress theme
Echelon WordPress Theme
Echelon wordpress theme
Dejavu WordPress Theme
Dejavu wordpress theme
Modular WordPress Theme
Modular wordpress theme